[SOLVED] Boot loop on Moto Z play

I’ve a Moto Z Play, I’ve been using /e/ OS for a few months and it worked quite well. Today the phone froze while I was using it. I rebooted and since then it’s stuck on /e/ logo (= boot loop).

  • I was not updating system, I was just using phone
  • I can enter in TWRP recovery, use adb shell, etc…
  • I already did cache and dalvik cache wipe, and rebooted without SIM nor SDcard and it didn’t work
  • I managed to dump boot log ( adb shell cat /sys/fs/pstore/console-ramoops > ./boot-loop-kernel-log.txt ) but I can’t understand what is failing

I uploaded my logs here: drive.google.com/open?id=1ekTRe_dWSLKq8TmLqa26uae0SOE9uccy

There are 3 files:

Number 1: I let the phone reboot several times, the log is 150 seconds.
Log number 2: I switched to recovery as soon as I detected the phone rebooted, so log is only 30 seconds. The phone makes a small vibrations at every reboot. However the screen always shows the /e/ OS logo.
Log number 3: again I let the phone reboot several times.

Perhaps some hardware might be failing… perhaps the camera or the GPS… On the web I saw a post of somebody stuck in loop because of screen temperature calibration fail, he deleted a file (that doesn’t exist on my device) and solved the problem; but my problem is that I can’t understand boot log, I can’t understand what is going wrong. Can you help me?

I solved the issue. I went to TWRP and did a simple wipe. I didn’t want to do this because I was going to loose all my apps and configs, and actually I lost them, but at least device is usable again.