[SOLVED] Can Teracube 2e with /e/OS use USB for data tranfer?


I’m trying to migrate into my new Teracube 2e, bought from Murena with /e/OS preinstalled.

The phone comes with a USB-C to USB-A cable. When I plug this cable into the phone and my computer, there is no notification that allows me to switch from charging only to data transfer. Additionally, no listing for the phone is present in the output of the lsusb command on my computer.

At first I thought this was a cable problem, but I tried several other USB-C to USB-A cables, known to be working data transfer cables, and none of them cause the USB mode switch notification to be displayed on the phone, or the phone to be recognized/listed by the computer.

Is this a problem with the USB-C connector on the Teracube? Or is there some other aspect of /e/OS notifications or USB modes that I’m not getting right?

Thanks for any help…

John A

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Check Settings>Connected Devices>USB while the USB is plugged in. You should find what you are looking for there.

Thanks for your reply Dave1!

I accidentally discovered the problem. When inserting the USB-C cable into the teracube, it didn’t want to go in. I had to push it from an angle to get the cable to go into the connector. Even then I had to wiggle the cable around before even the charging mode would be entered.

On one re-insertion of the cable, I pushed it harder than before and it seemed to snap into place! After this the USB mode notification was displayed, and the phone was listed by lsusb on the computer.

After enabling developer options, and android debugging, now I’m able to adb shell into the phone and transfer files.

Thanks again for helping people on the forum!

John A