[SOLVED / Can't Reproduce] Problems building Nougat for condor

I’m trying to build for condor on a Vultr instance with 640 GB SSD and 33GB of memory
Build command was

$ docker run \
-v "/srv/e/src:/srv/src" \
-v "/srv/e/zips:/srv/zips" \
-v "/srv/e/logs:/srv/logs" \
-v "/srv/e/ccache:/srv/ccache" \
-e "BRANCH_NAME=v1-nougat" \
-e "DEVICE=condor" \
-e "REPO=https://gitlab.e.foundation/e/os/android.git" \

The build got to 99% before failing :frowning: The last part of the output is in this pastebin, and teh last few lines are

Error: ['mkuserimg.sh', '-s', '/srv/src/NOUGAT/out/target/product/condor/system', '/srv/src/NOUGAT/out/target/product/condor/obj/PACKAGING/systemimage_intermediates/system.img', 'ext4', 'system', '939524096', '-D', '/srv/src/NOUGAT/out/target/product/condor/system', '-L', 'system', '/srv/src/NOUGAT/out/target/product/condor/root/file_contexts.bin'] command unsuccessful
Out of space? the tree size of /srv/src/NOUGAT/out/target/product/condor/system is (MB):
1059    /srv/src/NOUGAT/out/target/product/condor/system
The max is 896 MB.
[ 99% 34781/34785] Construct recovery from boot
ninja: build stopped: subcommand failed.
make: *** [build/core/ninja.mk:152: ninja_wrapper] Error 1
make: Leaving directory '/srv/src/NOUGAT'

#### make failed to build some targets (01:14:51 (hh:mm:ss)) ####

which looks like a disk space problem. I thought 640GB would be plenty.

Can anyone give me any pointers as to what the actual problem is and/or how to fix it?
Thanks very much

PS At the end of the build there was nothing in /srv/e/zips/condor/ or /srv/e/logs/condor/

It’s a known issue and it’s reported at github. You can only wait til e.foundation as removed some items which are placed in system.imh

or you can use my minimal build [UNOFFICIAL BUILD] minimal eOS pie version

1 Like

Thanks. What I’m interested in is building the ROMs, using docker to start with. Are you saying that that isn’t possible at the moment? Or is it possible with a different docker run command? The ROMs I am trying to build are all nougat rather than Oreo or pie

Is it this issue?

Is the build likely to fail for non-supported devices too? I was hoping to build unoffical ROMs for Moto E 2015 surnia and Sony Xperia Z5 Compact suzuran. Should I just try it and see?

It’s failing on a lot of devices. On my bacon (that’s why I have made the minimal version) on Hammerhead and some more.

And yes, that’s the right issue

I tried to build the suzuran ROM and it worked :slight_smile: I then tried again to build condor, and that worked too.

Looking back at my notes I can’t see anything I did differently. The joys of software :slight_smile:

Anyway, thanks for your help

I’ll change the title of the post to [SOLVED / Can’t Reproduce]

Made a repo sync? Could be that the sourced a reduced in the meantime

Possible I guess. I believe the docker run includes a repo sync.

Yes, docker is always syncing. One point of a lot why I’m hating docker building

Hi, I’m also facing this issue but I don’t want to build a minimal version, I just want to know how to remove the packages I want.

The error is :

The tree size of peach is 1019 MB
The max size is 1024 MB

So I just need to remove a tiny little thing to make it worked (actually it should work since the max size is higher than the tree size).

For now, I removed the wanted directory (Local Terminal or MagicEarth for instance) in out/target/product/peach/system/app. I’m waiting for my build to finish to see if it will re-make the deleted packages or if it will build without.
EDIT : looks like it re-makes the package…

you can remove all prebuilt apks. But not bliss. have a look into my 1312.sh script. there you can see which apks could be removed and which not. So you can try one by one.

1 Like