[SOLVED] Can't store any data on internal device storage (Galaxy S8)

Hello dear community,

have successfully installed the latest /e/OS on a Samsung S8 (SM-G950F) with TWRP Version 3.3.1-0-dreamlte - Everything has worked so far. System booted, setup went through; no problems. No errors.

My problem:
Although enough internal free memory (11% of 64GB used) is displayed under Settings, I cannot save any data.

For example, when I want to take a screenshot, I get the message “Can’t save screenshot due to limited storage space” - although enough is displayed.

I can’t install apps from the “Apps” store of /e/OS - just crashes. Can’t seem to access the internal memory either.

When I try to download an .apk with the integrated browser, I get the message “Not enough space”… always the same…

What am I doing wrong?

Thanks for any help!

P.S. tried out the last two releases of /e/OS for Samsung S8:
Can’t be done for both.

Edit: found solution via google :smiley:

Solution: It worked for me to boot into TWRP recovery, go to advanced options and “fix contexts”. It fixed my permissions and I was able to save to internal storage again


Hello, welcome in the community :slight_smile:

Nice that you solved this yourself and shared the solution :+1: