[SOLVED] Default File Manager Unable to Install App


I tried to install the downloaded apk from the default File Manager however it won’t allow me or nothing happened. But when I tried a third party file manager and allow it to install unknown apps from the settings, I successfully installed the app.

Does it mean the default File Manager is not capable to install apk or is there any setting that I missed?

1 Like

I was able to install the F-Droid apk with the default file explorer after I installed /e/-Nougat back in October.
I hat to enable Unknown sources for app installation (in Settings -> Security -> Unknown sources).

Maybe your problem is device or apk-related. Can you name your device and the apk that you tried to install?
Have you tried to install other apk’s?

Installation from F-Droid, Yalp Store and other third apk store is working. Under ‘Install Unknown apps’ the default file manager is not in the list. When I use a third party file manager (Total Commander is what I’m using), that app is included in the list that’s why I able to install apk from there. I’m using version 0.2-201901042439 on my Mi A1 phone.

I tried the same apk in the default file manager and the third party file manager. I also tried other apk but the installation from default file manager is not working.

So this problem seems to be Oreo-(v0.2)-related (can not replicate it on my device that has Nougat) and it is not yet mentioned on gitlab.

Can you please create a bugreport about this issue as explained on this site: https://gitlab.e.foundation/e/wiki/en/wikis/issues
It is easier for the devs to track these problems on gitlab than here on the forum.

Have you tried installing the apk from the internal storage.

In the default file manager assuming your apk is in the Download folder select it and move it to the root of the MiA1 folder …by selecting MiA1 Icon showing in the hamburger icon on top left. Can you try installing it from there.

Well that solved it. I need to go to the internal storage first then Download folder in order for me to install the apk.

Thanks for the help @Manoj @Markus