[SOLVED] /e/`s Bromite web viewer has Stanford listening on Microphone?

I noticed something odd when looking through the settings on /e/`s Bromite web viewer.

In the web viewer settings / site settings/ microphone is enabled for stanford.edu

Maybe its nothing, but as these eductional places work on various projects i cant help wondering why this particular site was enabled, and if there is some rogue code element embeded…

I have since deleted this entry and blocked microphone, but was enabled by default as part of /e/`s rom which included the browser,

Hi @freedapeoples, pl can you raise this as a bug in Gitlab. I will pass it on to the dev team to check. Never seen this issue being raised or reported by any user before. Can you attach a screenshot of where you are seeing this setting. It shows blocked on my phone .

As soon as i deleted the entry, it occured to me afterward that i should have taken a screen shot.

Yes the picture u show is right, now if u click microphone (blocked) ,then that menu it shows microphone is blocked but there is an exception underneath for stanford,edu which was set to allowed.

It too late to screenshot but i`m sure another user will find it ?

It was on this page underneath where it shows microphone blocked was an exception with a stanford.edu web adress set to allowed.

If another /e/ user see`s it can u take a screenshot plz. thxs

All blocked here as well.

The screenshot you have shown is the pre-screen, it also looked the same on my phone too, now from that screen you have shown choose microphone, and it will take u to the microphone setting as it looks on my picture,it will also say microphone blocked but then underneath there was a exception with the stanford web url and there was another switch that was set to allow (next to the stanford web url).

If no one else finds it, then its very strange i have not visited stanford.edu web page, i defintily did not allow my microphone for any websites ever. The only thing i can think of was some app that i installed toggled it without my permssion.

I urge everyone to check within the bromite web browser settings>>> site settings>>> and select microphone>> and see if there is anything listed underneath microphone blocked. if not then all is well and i apologize.

Don’t see it here am I missing something?

Checked on 3 /e/ devices, athene,titan, flounder. All ok.

Done : no exception for me, micro blocked. /e/0.7-n- unofficial, France.

I would prefer it to be blocked rather than the “ask first”: toggle being actuated.

Thanks for checking, good to know.

Thanks for checking your 3 devices, it is rather interesting that your screen is different from mine, i do not have that option to ask first, mine just says blocked like the picture i had posted earlier.

I am going to change the title to solved, even tho i have no clue how stanford.edu was able to toggle my microphone, it is a mystery as i`m sure i would have noticed that a website wants to access my microphone i would have been alerted and in no way would i have granted access. I can only assume it was one of the IM messengers i installed whilst testing and somehow they sneaked in this permission, a messenger is the only thing that would ask me for permission for microphone and i would have granted it.

Same for me, micro blocked (/e/0.9.20200514…), France.

Sorry for the scare folks, i had been trying to rack my brain on how stanford.edu toggled my microphone, then it occured to me many, many, may, many hours later that i was reading in the /e/ forums a couple of weeks ago about proposals for voice recognition projects for /e/ then i remembered someone had mentioned the mozilla voices sampling, and then a few links and clicks later and i do believe i ended up a site testing word recognition, and may have infact given that website microphone permissions, yes i feel dumb now. The /e/OS is awesome i am ashamed of my panic :hot_face:, i just couldnt remember doing it, and took many hours later to retrace my steps. Keep up the good work, and thanks to those that took the time to reply and check their phone settings! :blush:


Thanks for clearing that @freedapeoples. Closing the topic as it is now resolved.

1 Like