[SOLVED] Eduroam not working

Today at work I tried to connect to eduroam. It didn’t work. Could connect to the eduroam wifipoint but no data was transfered.

Setting for this connect are:
EAP-method: PEAP
Phase 2-verification: None/Not validate
CA-certificate: Not validate
Identity = username@domain
anonimoius identity: empty
Password = *******

Anyone an idea?

Hi @Damio have you tried this app with LineageOS4MicroG ROM’s? Wanted to verify if this is an /e/ specific issue. Please can you also add details of your device + build version of /e/ you are on and also if you were able to connect to the app earlier or this is the first time you are trying to connect.
Pl raise an issue on gitlab attaching a Logcat with the issue. I am assuming this is because the app may not be working with MicroG but without the logs and details it would be difficult for the dev team to figure out.

@Manoj Eduroam is not an app but the worldwide wifi network for education. It’s kind of enterprise wifi.
Look at https://en.wikipedia.org/wiki/Eduroam.

So i’s not an app issue but an networking issue. Yesterday I discovered another bug in /e/. I tried to connect to the wifi network at my girlfriends house and the behaviour was the same. It connected and after that no data was transfered. After a reboot the network at my girlfriends hous was working fine. So it looks like a broader wifi problem. Something like: if it was connected to a wifi network before it won.t connect to another. Leaving my own house and returning did work fine.

Hi @Damio thanks for the clarification. I was not aware of this being a network and not an app :frowning: .
So to get this correct you are saying that a new wifi network even if configured correctly does not automatically start without a reboot. With Eduroam it does not work even with a reboot. Is my understanding correct?

@Manoj Not exactly. I have had a working wifi connection at my home. This was the only wifi connection I used until yesterday. Arriving at work I tried to connect to Eduroam. Connection established but no data transfer as described above. (no reboot, because i expected it to be an protocol issue, as it was on sailfish in my past). But yesterday evening i tried to connect to my girlfriends wifi resulting in the same behaviour as with eduroam (good connection, no data tranfer). After reboot, it connected flawless to the wifi network of my girlfriend. So it seems something isn’t ok when connecting to a new network. (Before rebooting i tried plane mode and it didn’t help.)

I had LineageOS on my phone and eduroam worked for me. Maybe you need to install a network certificate. I was required to install the eduroam app in the play store, and required to keep it since the app contains the network certificate.

1 Like

@Dave_Hulst thnx will try this.

1 Like

Eduroam settings are sometimes a bit tricky to configure, but it works fine for me, running the latest /e/. Our network requires EAP-method to be 802.1x EAP.


This week Eduroam worked flawless. Did nothing else. :roll_eyes:

Maybe you could ask some other people if they have problems with Eduroam too, on my school I’ve had some trouble connecting, after a few retries it worked. But it seemed everyone had that problem. As we see it: Eduroam sucks :joy:

1 Like