[Solved] Erasing Data on OnePlus One - Missing Wipe Setting in Recovery Menu

Hey there,

so I wanted to install /e/ on an OnePlus One and followed this tutorial: https://doc.e.foundation/devices/bacon/install

Sadly I got stuck at “Installing /e/ from custom recovery”, because I’m missing the described entries in the Recovery menu.
There I can only see:

  • Reboot system now
  • Apply update
  • Factory reset
  • Advanced
    • Reboot Recovery
    • Reboot to bootloader
    • View recovery logs
    • Power off

I guess the menu is different, because I installed CyanogenMod before (At the top there is the CyanogenMod Logo).
I tried Factory Reset, which deleted all my data, but not the OS.

Not quite sure were to go from here.


Hey, welcome in our community :slight_smile:

I think you should install TWRP.

Hi and thanks for the welcome! I think I did that… I just tried again and got this log:

C:\Users\Johannes>fastboot flash recovery twrp-3.3.1-0-bacon.img
Sending 'recovery' (13886 KB)                      OKAY [  0.470s]
Writing 'recovery'                                 OKAY [  0.190s]
Finished. Total time: 0.670s

However I still get the cyanogen menu when calling adb reboot recovery afterwards

Sadly I can’t help you more, wait for somebody else.

Still, thanks a lot, I now understood that the problem was the bootloader. I found the solution here: https://forums.oneplus.com/threads/help-after-install-twrp-recovery-phone-reboots-only-to-cyanogen-recovery.306774/#post-11437424

Seems like Cyanogen likes to overwrite the bootloader, but you can work around that :slight_smile:

When I swapped from UT to e on my bacon I have first installed the stock rom. Than I have flashed TWRP via fastboot. After reboot into TWRP I was able the push the e.zip to the internal storage and could flash it via twrp.
I have used twrp-3.3.1-0-bacon.img

Hm, interesting! For me it worked to get to TWRP by rebooting directly into the bootloader (by pressing Volume down and Power button at the same time). So in what I did was:

Doing things in this order allowed me to finally boot into TWRP recovery:

  • Run fastboot boot twrp-x.x.x-x-bacon.img
  • Run exit to close the command line
  • Unplug USB cable from phone. Phone screen should still say Fastboot Mode.
  • Hold power button, till device powers down.
  • Press and hold Power & Volume Down until devices starts and a bbit longer. If you hold it down too long you might power it off again.
1 Like

Don’t know from what OS you where coming. I have to flash stock rom first, because I have had UbuntuTouch on it and for e.OS not all firmware was available. Flashing without all needed firmware ends with error 7.