[SOLVED] Fairphone 3 error when trying to flash boot

hello everyone,

i am currently trying to install /e/ on my fairphone 3 and followed exactly the steps from

but there seem to problems when wiping and flashing the boot.

to be more precise when trying ./fastboot -w, i get

Android % ./fastboot -w
Erasing ‘userdata’ OKAY [ 0.176s]
/Users/User/Applications/Android/./mke2fs failed with status 1
fastboot: error: Cannot generate image for userdata

and when trying :/fastboot flash boot boot.img i have

Android% ./fastboot flash boot boot.img
fastboot: error: Couldn’t parse partition size ‘0x’.

all the other steps in the above link work perfectly fine.

for the first problem, i have already tried

ln -s /usr/local/Caskroom/android-platform-tools/27.0.1/platform-tools/mke2fs /usr/local/bin/mke2fs

but that did not fix anything. i am using mac os and the latest version of adb and fastboot. nobody else seemed to have especially the second problem.

thanks a lot for all suggestions how to fix this in advance!

Does it make a difference, if you use the following?

/usr/local/Caskroom/android-platform-tools/27.0.1/platform-tools/fastboot -w
/usr/local/Caskroom/android-platform-tools/27.0.1/platform-tools/fastboot flash boot boot.img

wiping works now, fastboot flash boot boot.img sadly has still the same error! thanks a lot anyway!

You are not alone, look here @Manoj another one with this problem. …


using fastboot flash boot_a boot.img did the trick (in my case the slot was b, so fastboot flash boot_b boot.img), thank you so much! i feel a bit stupid for not being able to find the thread you have posted. thanks a lot <3


Good for you, no you are not stupid i just posted it yesterday. There is something strange going on. Can you give some details to narrow down the issue… what fastboot version did you first use? What OS version was on FP3 before flashing?

1 Like

i ordered the phone last week and it arrived today. previous os version was the straight out of the box version, whatever that might be (i guess some android 9 version, unfortunately i did not check this). fastboot version is 30.0.4-6686687. mac os version is 10.15.6

1 Like

Thanks for the details. This issue where the user needs to check the active partitions before a fastboot flash is being added to the documentation. I was checking for more information as to under which cases this error occurs.


The same worked for me, too, with the same error with fastboot flash boot on a FP3.

I got through the whole documentation but sadly ended up stuck in the bootloader, rather than with /e/OS, but I guess that´s a different topic - I´ll try to find out.