[SOLVED] FP3 OTA update deleted by mistake

Hey there,

I got notified earlier today that a new update was available for my device (FP3). I tried to apply it but the download would fail consistently immediately after starting. Given it was stuck on a view with a loading bar and a “Resume” button (hitting it would just show me the same error) I held my finger on it and clicked “Delete” in the resulting modal, which I understood as deleting local data on the update so it would show me the “Download” button again.

However, doing so removed the update from the updater, which now shows “No new update found”. Hitting the refresh button on the top right corner shows it’s refreshing the list, but doesn’t bring the update back.

Is there a way for me to access this update again? I’m happy to download a file and flash it but I’d rather not have to wipe my data as https://doc.e.foundation/q-upgrade-fp3 suggests is needed for a manual update. It’s the first time the updater has been suggesting an update for the FP3 in the past 4 or 5 months, so I’d prefer not having to wait that long for the next one :confused:

Edit: If it helps, the Android version on my phone is 9.

1 Like

Hi there,

Similar situation here FP3 as well, I’m on 0.11-2020083170821 (stable released not unlocked)
Few month the updater not showing anything, until now, when I saw notification the updater got an update for 0.13 16 hours ago, but the clicked refresh (don’t know why), and it disappeared.

The main issue for me is the Maps app that is too outdated in my version to use online maps.
Was the update pulled?

Same problem with Samsung S9+ from /e/store.The update was suddenly gone.The phone has 0.11 stable version.The new update was 0.13.
How to fix this?

All: The stable channel builds were published at 10:20 PM UTC yesterday but disabled at 8:00 AM UTC
The reason behind this was a pop up showing that the build was made with public keys
which is not correct
…this issue is logged here
Note this issue only appears in stable builds and the team is working on resolving the issue. The fix will be merged and the builds released ASAP.


Makes sense, thanks for the update! :slight_smile: