[solved] FP3 update 0.12-p-2020100376806 went wrong


today in the morning I tried to update to this recent version. This was a mistake, it now enters recovery mode telling me “Can’t load Android system. You continue to get this message, factory data reset and erase a device.”
I would love to not factory reset, so maybe you can tell me how to roll back the update. As far as my research brought up, there are two install slots on the system. The recovery shows me I am on slot A, but using “fastboot getvar current-slot” does not proceed with “< waiting for any device >”.

Are there any ways to dig further in? It seems TWRP is not on my device so a lot of hints I found cannot be easily followed.

Thanks for the help.

Thanks, but as I said, the fastboot command does not proceed, just showing “< waiting for any device >”, but by rebooting continously I was able to switch to slot B at one point…pfff, it came back.

1 Like

Have you allowed USB Android Debugging in the dev options ?

Did you boot the phone into Fastboot Mode by starting or rebooting it with keeping Volume - pressed? The fastboot command only works in Fastboot Mode.

This would be necessary for the adb command and should have nothing to do with the fastboot command.

So, yes I entered the fastboot mode at one point, I expected that the recovery mode already activated that. Anyway, I have been able to switch to the other slot.