[SOLVED] Gigaset GS290 Update to 0.18 failed

Hey /e/ people,

I got a Gigaset GS290. There’s /e/OS 0.17 installed and today I found 0.18 available for update in Settings–>Systemupdates.
After download I tapped “install” and the phone reboots into eRecovery 0.14 at about 20%. But within eRecovery nothing happens. :frowning: There’s no progress bar etc. visible, just eRecovery. When I choose to reboot the system manually the phone comes up again with 0.17.
Do you have any advices for me? How can I perform the update?

kind regards

You are probably hitting a similar issue as described here:


Trouble is, your recovery image is from dev branch since the installation (0.17 is probably the first version you’ve flashed on the 'set), and can’t verify the signature of the downloaded image from OTA.

I’ve fixed it by flashing the 0.18 recovery image from the stable branch. If you think the same issue affects you do the following:

Download https://images.ecloud.global/stable/GS290/recovery-e-0.18-q-20210827132306-stable-GS290.img and verify the checksum https://images.ecloud.global/stable/GS290/recovery-e-0.18-q-20210827132306-stable-GS290.img.sha256sum

Enable developer options, enable usb debugging, connect GS290 via usb cable and run:

adb reboot bootloader
fastboot flash recovery recovery-e-0.18-q-20210827132306-stable-GS290.img
fastboot reboot

After that run the OTA again.

But you could wait for someone at /e/ to confirm the procedure.

Best of luck…

PS. I’m asuming you’re on the stable branch, if not you should download recovery for the dev branch, but I’m not sure what’s the correct link, I’ve guessed the stable one from previous naming conventions :slight_smile:


The same here. I installed /e/ some weeks ago manual following the instructions here on the site. You get the 0.14 dev version of the recovery when you use the download link. I think they should update this.
I then downloaded and installed the 0.18 stable version and everything is ok now.

Thank you so much! I can approve these steps are valid to get the update mechanism working again.
It seems that the manual installation instructions are kind of abandoned…

I really would like to mark this thread as solved but cannot find a way to edit the topic.
kind regards


Please post here about documentation suggestions.
And ask @Manoj about the thread title change.

1 Like

Both is done, thank you all and have a nice day! :slight_smile:

1 Like


I don’t know if I can help but, I have also a Gigaset GS290. At first, I went to Settings, and download /e/OS 0.18. Then, after download it, I have installed it. Then, the phone reboot, and then come back normally, that’s to say, the phone ask your sim card code and after your password if you put one on it.

Maybe, shutdown and reboot your phone.


Same here, been stuck on version 0.16 because of this. Any idea how I can bring my phone to do that step automatically, because it seems easy installer users don’t have that issue.

And is it normal that the phone is in orange mode? I’m having it since the beginning.