[SOLVED] Help needed: How to install/upgrade Magisk on Samsung Galaxy A5 2017?

Hi all,

I’m running /e/ 0.12-p* on a Samsung Galaxy A5 2017 (a5y17lte) device.

When I first set up the device with /e/ (I think it was version 0.10) I’ve also installed Magisk via TWRP and this went fine and everything worked as expected. Now, as I wanted to use Magisk-Hide for a new installed App I found out that there Magisk is not working/installed anymore:

Screenshot_20201121-123018_Shade_Launcher

and I’m not able to install it via TWPR anymore.

I also tried to follow the new install instrucions on https://topjohnwu.github.io/Magisk/install.html but didn’t succeed as fastboot isn’t working with Samsung devices.

Has anybody succeeded in installing Magisk with latest /e/ version on a similar device and can give me support?

Thanks a lot!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I would download and run MagiscRemover tools and than, after reboot I would try to install latest Magisc once more

1 Like

Thanks a lot @harvey186! This solved my problem.

I’ve than installed Magisk by

  1. install the latest Magisk manager (recommended here )
  2. using installation method downloading .zip file and
  3. flashing the .zip file with TWRP

For some reason with this method Magisk version 20.4 has been installed instead of the latest version 21.1. But everything works fine now. :+1: