[SOLVED] I think that I bricked my new Oneplus 5T

I may have bricked my device- everything went well until the very end. I successfully unlocked the bootloader, then installed custom recovery. I did a backup of the original system to the 5T and then followed these instructions:

  1. Now tap Format Data and continue with the formatting process. This will remove encryption as well as delete all files stored on the internal storage.
  2. Return to the previous menu and tap Advanced Wipe.
  3. Select the Cache and System partitions to be wiped and then Swipe to Wipe.
  4. Sideload the /e/ .zip package:
  • On the device, select “Advanced”, “ADB Sideload”, then swipe to begin sideload.

I sideloaded the OS and the phone indicated that the sideload was successful.

The next instruction was to reboot the phone. I think that this is where I made my mistake TWRP asked something like “are you sure you want to reboot? No OS installed.” I went ahead and rebooted. Now my phone boots to the warning message about the unlocked bootloader. Once that passes, it boots to a black screen. The indicator light is blue but the black screen remains. I can reboot the phone but cannot access TWRP any longer. If I reboot with the volume up key pressed, I do get the fast boot screen. FASTBOOT on my PC can see the device but ADB cannot. When I launch the recovery from the Fastboot screen on the phone, I get a black screen again. Apparently, TWRP is gone. Can anyone suggest what I can do next? Thanks.

Download stock rom of your device and flash it as it is written on the site where you have found the stock rom.
If stock rom flashed successfull you can start over wirh e

You could try to re-flash TWRP first:
fastboot flash recovery twrp-x.x.x-x-dumpling.img

I did re-flash TWRP. The flash was successful but I still can’t boot into it. Unfortunately, everything I’ve found regarding returning to stock ROM requires TWRP. I need some solution that would work with Fastboot as it is the only thing I can access.

Hmm, what happens when you type fastboot boot recovery twrp-x.x.x-x-dumpling.img

a working kernel is missing. That’s why TWRP won’t work. You have to find a stock rom or any other which is flashable via fastboot

try flashing thishttps://ecloud.global/s/XacDW8NbYFCbNws boot.img with
fastboot flash boot boot.img
than flash twrp again and reboot in twrp

Hope it will work

Thanks to both of you for your help. I tried booting directly to the TWRP via Fastboot. I also tried installing the boot.img that Harvey provided. You can see from the output below that the inputs worked. However, I still cannot boot to TWRP from the phone. I’ve powered down the phone and then rebooted to fastboot and selected “recovery”. Again, just a black screen with a blue indicator light. I don’t understany why Harvey’s boot.img didn’t work…

Thanks again.

$ fastboot boot recovery twrp-3.3.1-0-dumpling.img
fastboot: error: cannot load ‘recovery’: No such file or directory

$ fastboot boot twrp-3.3.1-0-dumpling.img
Sending ‘boot.img’ (33684 KB) OKAY [ 1.051s]
Booting OKAY [ 10.108s]
Finished. Total time: 11.684s

$ fastboot flash boot boot.img
Sending ‘boot’ (23193 KB) OKAY [ 0.733s]
Writing ‘boot’ OKAY [ 0.005s]

$ fastboot flash recovery twrp-3.3.1-0-dumpling.img
Sending ‘recovery’ (33684 KB) OKAY [ 1.038s]
Writing ‘recovery’ OKAY [ 0.011s]
Finished. Total time: 1.067s

Sorry there was an error in my command. This is the correct one, this should boot TWRP. This does nothing?

Correct- it reboots the phone but does nothing else. The phone shows the Oneplus logo and “Fastboot mode”. Then continues onto that black screen.

You could try another TWRP version, i’ve seen non working TWRP versions (i had it yesterday!). This is another version dl here I suggest to boot it to try. fastboot boot twrpname.img

Thank you- there is a difference- this particular TWRP version that you suggested reboots the phone. Again, I get the Oneplus logo along with “Fastboot Mode” but this time the phone gets stuck on this splash screen and there’s a red indicator light. When I remove the USB cable, the red light turns off and the splash screen remains. Any idea what this means?

I just flashed your TWRP to the phone and then booted to recovery via Flashboot- It worked! I have no idea what to do from here but at least there’s hope- thank you!

Welcome, i know how it feels when you have no idea whats wrong with the phone :grinning: Now continue the instructions here step 8 Sideload the /e/ .zip package:

I can’t thank you enough for your help. I’m sure that you have better things to do than spend your time on my phone. I can only repeat my appreciation. I have followed the instructions from step 8. Again, the ROM installed successfully. And also again, when I go to reboot the system- TWRP warns me that there is no OS installed and asks for confirmation of reboot. This is what happened the first time. Would you advise I reboot anyway or should I flash another ROM?

Hmm strange, i’m not sure where the “No OS installed” comes from. You’ve just installed an OS. Maybe first boot into TWRP again. And then the OS. If it still does not work you can try to download another /e/ build.

After uploading the zip file to the phone, in TWRP, do you do : install / select zip file ? wait until install is done and then reboot
Might seem to be a dumb question… but who knows…

Yes, I did. After running out of ideas, I went ahead and rebooted- first to recovery and then to the system. It booted /e/. Again, thanks to all of you. This is a great community. I hope that I can give back as I become more familiar with all of this.


Glad to hear it’s finally working. It must have been a stressful experience.
Enjoy :wink:

Well i’d like to know how the camera performs on the oneplus 5t. I’m searching for the best “e-camera” phone. Maybe you can post some pictures on the forum. I’m happy you’ve got it installed, enjoy /e/ !

1 Like