[SOLVED] Installing /e/ on a soft bricked FP2

Hi everyone :slight_smile:

I need help :pray:

I want to install /e/ on my fairphone FP2 but I want to do it right because I made a mess with my phone:

  • I was using LineageOS (LOS) 16 for Microg
  • I saw LOS was in version 17
  • sideloaded LOS17 without wiping anything (big mistake, I forgot I was using LOS16 for microg before)
  • surprisingly it was working quite well (except the location with wifis, cells)
  • I started to sideload some zips to try to get microG working, and it broke my phone
  • then I wiped cache and dalvik and sideloaded LOS17. But the phone was no usable. Home button not working, no mobile data, internal storage broken, … (I had my sdcard configured as internal storage)
  • then I wiped everything (system, data, cache, dalvik) and sideloaded LOS16 for microg, in order to get back to the previous working state of my phone with a clean install.
  • but now, when I start the phone, I see LOS animated logo during a long time and finally it boots on recovery

For recovery I am using TWRP 3.3.1-0. I’m not sure if it is the regular version or the FP2 version (https://eu.dl.twrp.me/FP2/)

Do I have to install twrp-3.3.1-1-FP2.img ?

Do you think that following the instructions here https://doc.e.foundation/devices/FP2/install it will be good ? Or given my phone brick context I should do some extra operations ?
Like doing a format data (I don’t really know the difference between format and wipe), or wipe also internal storage and sd card ? …

I’ve been playing around with different OSes and versions on my FP2 and kind of soft bricked it a handful of times.

What always got me to a fresh start was the manual installation of the default Fairphone OS (maybe followed by an additional factory reset).
That plus letting the phone cool off between to many OS installations (taking out the battery in between).


AFter a brick it’s always the best way to flash stock rom. In 99,99% it will reanimate the device


Thanks a lot for your replies. I will try that. Do you think I should install twrp-3.3.1-1-FP2.img ?

Normally it’s the ebst to use the latest, so yes. And it’s from last year, so if it have had any issues they should be resolved in the meantime

1 Like

If your data partition was encrypted before or maybe also as you write that you’d used your SD card as internal storage (something I wouldn’t recommend) then it’s good advice (and often necessary) to also use the format function. I think the wipe (“only”) cleans the data but format also recreates the file system.
I’ve installed many systems on a FP2 but after wiping system, data, dalvik, cache and even formatting data it was always possible to install LOS or /e/. TWRP 3.3.1-1 is probably good. But I’ve been using TWRP 3.2.3 most of the time and it has always proved stable.

1 Like

I manually installed default FP OS. It was still not working.
I had a “no command” screen but I manage to enter the default recovery and performed a format as suggested.
Then FP booted normally !!!
I installed twrp-3.3.1-1-FP2.img and entered recovery.
It asks me if I want to keep the system Read only. I’m not quite sure what to choose. I got a “Keep read only” button and just below I can swipe “swipe to allow modifications”.

okay I got my answer here “If you are planning to flash a custom ROM, then move ahead reboot the recovery and allow twrp access to system modifications. Now are you are good to go with the flashing.” https://www.quora.com/In-TWRP-recovery-I-selected-keep-system-read-only-Will-I-be-able-to-use-custom-a-ROM

1 Like

Sounds great!
And btw.: the “no command” screen is the entrance screen of FP2 stock recovery system (you can go into functions by using ln/off+vol up. But you’ve managed that anyway :slight_smile: