[SOLVED] Losing network connection after update

Hi there, I did the last update yestarday to /e/OS 0.15-20210317106351 with FP3+ /e/ edition. Since then I lose network connection.

What I did to find the problem:

  • Airplane-mode, I can send one SMS after that I get the same issue
  • restart, see above
  • activate roaming, no solution
  • Manual APN-config, no solution
  • change SIM-slot, no solution
  • reactivate sim-card, no solution

Asside from manufactor reset I think I tried everything.

I checked with my provider, no network issues found.

Any solutions, suggestions, ideas, same problems anyone?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Solved. However, it was the SIM-Card.

1 Like

Hallo FFP3,

I have probably the same issue. From yesterday evening my connection LTE network status is as image shows.


Me too with the same /e/OS update version even if I don’t think it can be involved in the issue since for 5-6 days everything have been working perfectly.

I tried with APN settings, playing by add a new set (as per carrier instruction) and restoring default set. Completely unsuccessfully.

Could you pls be so kind as to share details about your fixing way? how SIM-Card is involved?

Many thanks in advance

Dear Luca,

I am afraid I can not help you with this. In my case it was a problem of my mobile provider. The SIM-Card was old (2017) and my provider stated that sometimes with the old SIM-cards there is a problem which occures after restarts e.g. related to updates/upgrades. I can not follow the comment of my provider, but however they sent me a new simcard and since then the problem was solved. I had no issues since then.

In your case I have no idea as the loosing of the mobile connection can be a result of many different issues so I am afraid you have to engage with the help-line of your provider.

Thank you for your kindness FFP3,

Don’t ask me why… LTE connection has been automatically restored without any modified setting or any other workaround…Probably a carrier problem. No other way to explain…

Many thanks anyway

Mee to, solved by resetting APN ( i think it was. )

  • Phone: Fairphone 3
  • Country: Sweden
  • Operator: Hallon

MMS did work in the old /e/ development version 0.11 something i installed october(?) 2020 and phone have been running nicely as my main phone all time except a minor issue :slight_smile: so i held off updating until last week.

After update to latest official, i could not surf without wifi, and MMS never worked receive nor send.

I have let it be for a week, including a few reboot and tries. Never a mobile data connection.

I tried to check if APN settings are correct, but in settings there is nothing at all listed under APN.
And there is a text saying this user can not access these settings!
Why cant they even be shown??

Anyhow i went through settings and mobile data off and on, set preffered type to LTE (was already, let it again search for network and selected hallon, then went to APN and selected (the three dots in vertical row top right) to reset to default, and rebooted the phone.

Now it works.

AND: now under APN there is content:
3 SE
data tre se

data tre se

Maybe we should rise a bug about initialising APN?

=> List of APN Values for Service Providers please :slight_smile:

Good idea. I now entered info there :slight_smile:

Just an idea why only a few of us see this:

My slow brain now remember an endevaour years ago when i changed phone, phone maker, and provider, and the new one first worked a couple days but then APN etc got misconfigured - i guess it synced down settings from old to new phone erroneously, used same phone number and (i think) google account.

So i wonder if maybe there is incompatible settings format from old dev version to the new version, and they got synced.

Had the same problem with my FP3+. Resetting APN helped, thanks! It occurs repeatedly for me when rebooting the phone. I think a bug report would be appropriate.

Yesterday i tried to let it update /e/, which failed, so i reverted.
Now APN settings are gone again, plus now it fail to reset :frowning:

As the update failed, i / we / the OS may have other problems as root cause…

I entered APN settings vanishes and cant be set -> No mobile data, no MMS (#3462) · Issues · e / Backlog · GitLab

@stefanhgm and others experiencing this:

Some probing:

  • Do the APN setting page display a message in grey tiny text that your user do not have access rights to the settings? When i see that text, Mobile data do not work, no setting is visible and it cant make new. I have not yet figured out when that happens.

  • Have you checked you are not logged in as another user or guest user? I have no other nor guest enabled.

  • Job profile enabled? Does not seem to matter for me.

  • Sandboxing like shelter? Does not seem to matter for me.

1 Like

That’s exactly how the problem also appears on my device.

@stefanhgm OK, please add some kind of “mee to” on the bug.

@stefanhgm and others: problem seem solved for me in /e/ version dated 20210621, see bug.
For anyone if it is not, please comment there.