[SOLVED] "No Service" error with working sim on Nexus 5

Hello everyone,

I’ve successfully installed /e/OS on my old Nexus 5, everything works fine except the mobile data.

I get the “no service” error when using my carrier sim, the phone correctly detects the sim and is asking for a pin to unlock.

I know the sim works because I’m currently using a Xiaomi Redmi Note 3 and the sim works fine there also the last time I used the Nexus 5 with another sim it worked as well.

I configured the APN following the carrier instructions on their website but it won’t work.

System version is 0.7-2020031745615
Android version is 7.1.2

Any suggestion?
Thank you.

What kind of rom was installed before flashing eOS ? Was it the stock Android 7 ? If not, you should go back to stock Android 7 and than start again with eOS. Hope the original firmware will solve the issue

And don’t forget to test the mobile network on original stock android to ensure that it isn’t a hardware issue

Hello, it was Android 6.0.1 Marshmallow.

I’ll try re-flashing stock android and see if that solve the issue.

I’ll let you know.

So… I re-flashed stock android 6.0.1 and looks like it’s a hardware issue.

I still get the “no service” error with the stock rom, sadness

very bad :frowning:

But could you please now add [SOLVED] to the headline of your first post ?

and stay healthy