[SOLVED] No sim card read after reset and no imei

On my galaxy s7 edge after a reset
No read the sim card
Imei unknown

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

To solve this kind of issue, I would flash the last version of the stock ROM (don’t do this if the last version is Pie or 10 since /e/ for S7 is on Nougat). Then flash TWRP and install /e/.

If I understood this posting correctly, carlopix uses a /e/ Phone with stable /e/ OS. Where can he download a new /e/ OS ROM?

I wonder why this error occurs now after a reset. So far everything worked fine.

@carlopix, what was changed on /e/OS before the reset occurred?

Yes i bought from e/shop. All it was working fine before reset i just wanted a clean os, but than not working the sim card and no imei… :unamused:
Any suggestion how to fix it?
Without flashing rom pls, i am not a modder :neutral_face:

Have you ever made a Nandroid system backup via TWRP Recovery and stored it externally, e.g. on microSD, since you first used your S7?

In this folders
[✓] Baseband
[✓ ] EFS
contains such important data as Baseband data and IMEI.number.


You did a factory data reset, right? S7: Settings > Backup & reset >> Reset Phone

No backup
Yes data reset
I have the imei on the box of the phone

Try this procedure first:

  1. Remove your SIM card from your S7.

  2. Restart a “Factory data reset” and set your date & language.

  3. Switch off the S7 completely once.

  4. Insert the SIM card and restart the S7 now.

  5. Check APN settings in your S7 under category “Wireless and Networks” you will find the item “Mobile Networks”.

Sorry i try but not working

Can you boot into TWRP Recovery?

TWRP Recovery :

With the device powered off,
hold Volume Up + Home + Power.
When the blue text appears, release the buttons.

Yes than what do on it?

For example, to install a flashable-baseband.zip.

“Without flashing” (installation) a repair will hardly be possible. You don’t have to be a “modder” for this simple activity.

What operating system does your host machine use?

Yes it works i flash lineage os and the imei is back and all it works fine.
I will try to put e/ back into it :grinning:
Many thanks again i flash a phone for the first time