[SOLVED] Oneplus 6 - No access to system after installing /e/ OS

TWRP for OnePlus 6

OnePlus 6 Install Instructions

Read these instructions and follow them carefully.

The OnePlus 6 uses the newer AB partition scheme first introduced on …

1 Like

This is what I have been following, and it has been successful. I don’t think my problem is with TWRP, I have been able to install it successfully. My issue seems to be the installation of /e/ OS itself.
After installing /e/ OS and rebooting, I am taken to fastboot, and am only able to boot into recovery mode, not /e/ OS itself.

So that means that LineageOS Recovery is no longer on your device, right?

1 Like

Yes, but from there I am still unable to boot into /e/.

In which way did you try to install /e/ OS?

  1. via adb sideload e-0.8-p-2020041649926-dev-enchilada.zip
  2. via TWRP “Install” e-0.8-p-2020041649926-dev-enchilada.zip
1 Like

sorry if my poor choice of words is causing confusion, I use adb sideload to install /e/.

Have you ever tried a “Super Clean Install”?

  1. in TWRP > Wipe > Format Data

  2. in TWRP > Wipe > Advanced Wipe >> select the
    /Dalvik / Art Cache
    /internal storage
    /Cache partitions to be wiped and then >>> Swipe to Wipe.

  3. In TWRP > ADB Sideload >>> Swipe to Start Sideload

  4. on Desktop PC > adb sideload e-0.8-p-2020041649926-dev-enchilada.zip

1 Like

I did receive this error message after sideloading, but that is all I could notice.

I have just done the ‘Super Clean Install’, and nothing has changed from the previous installations. Again, lineage OS recovery has overwritten TWRP, but this doesn’t seem worth fixing, as the problem of /e/ not installing properly is not fixed.

Picture 2: >>> Swipe to Reboot
Yes, this message is misleading, but >>> wipe right and the system will reboot.

This is incomprehensible to me, because we had determined “LineageOS Recovery is no longer on your device

Have you already tried (a)lternative?

Steps 1. and 2. as above.

3(a). Copy file e-0.8-p-2020041649926-dev-enchilada.zip from DesktopPC zu Internal Storage of Oneplus6

4(a). in TWRP Install e-0.8-p-2020041649926-dev-enchilada.zip

1 Like

I did indeed wipe right, and rebooted to same issue.

I reset the phone to stock (therefore I have stock recovery) > install twrp > install /e/ > reboot and I get Lineage OS recovery. Which I can then update over ADB to get TWRP, but it hasn’t solved the issue before.

I haven’t tried that alternative, so I will try it later or tomorrow.

Yeah, right now I’m at my wit’s end too.

1 Like

I installed /e/! I’ve updated my post so you can see how.

1 Like

Hi @Lance,
Thanks a lot for the solution!!! I guess I went through the same difficulties as yours. After bricking my phone twice, I followed very very carefully your [Howto] (I did not realise the versions of TWRP and Android were actually really important) and eventually I managed to install /e/ on my OP6! I’m really happy about this.

I have questions for you. Do you have OTA updates issues like some others users do in others posts? I haven’t had time to test.

Plus, I’m having troubles with three apps so far:

  • I could not download and install Brave browser from the Apps store but I got the apk from another device under /e/ (Samsung J5, still under the 0.8 version of /e/)
  • I was able to download ProtonVPN (the current one, not the outdated one) but it crashes as soon as I open it. Same as for Brave, I tried the apk from my samsung device, the app was called ProtonVPN 2.0 and it works well now. So not sure about what’s going on with the current apk.
  • Very weird, the Files app included in the OS works well but instead of saying “Files” just below the icon, it says: “@string/files_label”. Do you experience the same?

Finally, a newbie question: can I lock back the OEM to avoid the alert screen on booting? Or it will cause troubles?

Thanks a lot!

Hi @martin3418, I’m so so glad to hear you installed /e/, great job! I haven’t had a single issue since installing /e/ 2 months ago. OTA updates have been completely fine.

If you haven’t already tried, I recommend downloading F-droid and Aurora Store. I’ve experienced non-downloads from the /e/ App store, which I have rectified using these stores instead. Aurora store is basically the google play store without a google account; if you’re using /e/ I assume you’ve heard of F-droid. I’ve just tried, and both ProtonVPN and Brave work for me fine from Aurora store, but not from the /e/ app store.

I don’t share your experience with the Files app, and I can’t suggest what to do, but you could report it on github, or just make a seperate post about this issue, and some one more knowledgeable than me can comment on it!

Finally : I am also a total newbie, but from all the research I had to put in to installing /e/, I remember coming across this post about re-locking the bootloader, which I hope helps with answering your question.

Thanks for getting in touch with me have a lovely night! :smile:


Thanks @Lance for your clear (and quick) answer!
Yes, I did install F-Droid and Aurora. Re Aurora, it was not working well but I now know why. I was blocking the (google by the way) trackers with TrackerControl. I guess that Aurora fetches results from the Play Store, right? So I have to accept this…
I’ll raise an issue on Gitlab regarding my naming problem.
Thanks for sharing the post. After reading it carefully, I won’t lock it. I’ll try at least one OTA update first. If it works, then I won’t change anything as a user had OTA issues after locking back the bootloader. But if it does not, then I might rethink about it. But anyway, I don’t reboot very often my smartphone so it’s not a big deal.

Keep in touch!

I also use ControlTracker, it can be cumbersome at times! As for Aurora store, that’s the pay-off for using certain apps, unfortunately. I hope the OTA goes smoothly, and you’ll quickly get used to how minor the start screen message really is!
Bye for now :slight_smile:

Hi @Lance,
My first OTA went great!
However, I’ve got a couple of issues like a tracker control notification: “An unexpected error has occurred […] This is likely because of a bug in your Android version”

  • In Mail, in the folders list, just below the folder’s label, there is: “====== App-specific strings========”
    It’s quite minor but hopefully it will be fixed in the next update.
    Same for you?

Sorry for the late reply! I’m very glad to hear the OTA went well. I’ve stopped using tracker control for now, I’d prefer to use a VPN, and be sensible about what apps I do install, and run a hardened version of firefox for browsing. I also don’t use the mail app! I hope by now you have found another user who shares the issues. Even if you haven’t, they’re great for the /e/ team to be aware of, so they can squash the bugs in the next update.

Same for me. I think the folder should be displayed at tho top of the list and should not display this text.