[SOLVED] Problems with pictures (Gallery, Camera) on Fairphone 3+

Hey there,

I already posted the issue in the fairphone forum - unfortunately it is not solved until now. So I try again here (and in English) as it seems to me that this is a software-related problem I am having.

First of all thanks for providing the easy installer! It really helped me to install /e/ (Android 10,/e/0.15-q-20210317106351-stable-FP3) on my device!

I am quite happy with it. There is only one problem I am facing which is really annoying: the display of pictures. When I open the Gallery App (and I tried different ones) I always see something which reminds me of old TVs with no clear signal. I am not sure if “flickering” is the right word. After a small while the picture becomes “stable” unless I zoom into it or swipe to the next one. Sometimes the whole app gets unstable and the complete screen starts to flicker in a way that I cannot use the “back” option on the screen. As I have been asked this before - pictures are not stored on SD but internally.
The same issue happens when I open the camera (also here I tried different apps).

However, most other Apps I tried so far don’t show this issue. When I stream TV via Zapp it does not occur (only when I watch videos on demand i saw this flickering for the first seconds on rare occasion). The videos are shown with a very clear picture

My guess as a non-expert - something goes wrong when the picture graphics are calculated. It would be awesome if you could help me solve this problem. A friend of mine is also interested in installing /e/ on his fairphone but he is hesitating due the issue I ran into…


EDIT: it seems to not happen when I take a screenshot of my home screen and open it in the Gallery.

The problem was not with /e/ but with the hardware. After taking out the display, cleaning the contacts and putting it back in the problem seems to be solved.

Just wanted to let you know - in case someone has a similar issue. I could have saved a lot of time and trouble if I would have tried this at first - but i could not imagine it is hardware-related, as everything else worked fine…