[SOLVED] Redmi 3S no data

xiaomi

#1

Hi,

I just installed e-0.2-201811302123-nightly-land rom on my Redmi 3S.

Everything worked very well with e-0.1 but now neither my SIM 1 or 2 (I’ve 2 differents operators, Free and Orange) can reach any data network. Any ideas ? I can make calls and send sms, but accessing Internet would be great :slight_smile:

I wanted to post it on https://gitlab.e.foundation/e/wiki but it isn’t reachable anymore ? is it normal ?


#2

Gitlab is currently down. Devs are already informed about it.


#3

Are you sure that you have enabled “mobil data” ?? sorry, but sometimes overlooked at little things :wink:


#4

Yes it’s activated, I tried on both SIM


#5

Can you check your APN settings? I had this issue when I installed it in onyx. I had to call my telco to get the settings.


#6

Same issue if the good APN (orange.fr) is forced. I reinstalled e-0.1 just to verify APN and that my SIM are working well and everything is working fine on e-0.1. Then I rereinstalled e-0.2 and here no data :frowning:
I also tried to reset wifi/mobile data/bluetooth from system options but still not working.
Gitlab is accessible again I will post there.


#7

Does your Wifi working ?? If not, the modem.bin is missing. I have had the same issue on my Xiaomi Note 4.
For my Xiaomi device I have found a solution on XDA. SO I would prefer to have a search on XDA. Could be, that you will find a solution there.


#8

And if you are able to find a Oreo firmware for your device, flash it. Than you can flash v2-beta again and it should work.


#9

Yes wifi is working.

I will also try to install LineageOS based on Oreo in order to check if it’s linked with Oreo but for now I’m a little bored uninstalling/installing my system as it’s my only smartphone ^^ I’ll do it tomorrow. For now I’ve reinstalled e-0.1


#10

OK, good idea with trying LOS. Have a look on the log while flashing. I feel LOS get’s more/better logs while flashing as e does.

Understand that you have enough from flashing :wink: wish you a restfull day :wink:

by the way, that’s the link to XDA https://forum.xda-developers.com/redmi-note-4/themes/mido-modem-rn4-sd-mido-t3585360


#11

Well I tried to install LOS 15.1 > I don’t have any mobile data neither.
I guess I will reinstall MIUI… as on e-0.1 there are more & more apps I can’t install due to “apk is split error”.


#12

OK, that’s good, because it’s no e issue.
You are right, first flashing orinial nougat MIUI firmware and the e—v2
I hope than everything works fine


#13

FINALLY !! I reinstalled MIUI 9 with MiFlash.
Then reinstalled e-0.2 and it worked. I guess I wiped too much things during tests and flashes ! Maybe the “vendor” part.
\o/


#14

Perfect, so could you please edit the headline of your first post with [SOLVED]

Thx and have fun with e-v2


#15

I got the same problem, I have installed e-v2 two days ago on a Redmi3X, but I’m working on linux, so how could I do that without MiFlash?It’s only for windows…


#16

@Pitttuhau there was a tool created by a user on XDA which worked like miFlash on linux https://forum.xda-developers.com/android/software/tool-miflash-linux-t3708847 I have not used it so not sure how good / bad it is.


#17

Thanks Manoj, I will try it.


#18

No way…Sorry but I cannot find a solution, the tool workks, but It seems that nothing changes about the MIUI or nothing at all,maybe I do not find the extact path, or :sweat_smile:maybe I had enough installing correctly /e/…It is the first time for my running on phones, and i have to much to learn!


#19

How did you did it?I mean…made a hard reset before reinstalling MIUI 9 or…


#20

I don’t remember exactly, but yes hardreset, download last MIUI rom for your Redmi3S, you will have a file called something like land_global_images_V9.6.2.0.MALMIFD_20181010.0000.00_6.0_global_44ec48341d.tgz extract it with 7zip (or any other zip app) you will have then a file called land_global_images_V9.6.2.0.MALMIFD_20181010.0000.00_6.0_global_44ec48341d.tar
Extract also this new file and you will have a folder land_global_images_V9.6.2.0.MALMIFD_20181010.0000.00_6.0_global_44ec48341d.
Launch “XiaomiFlash” and select this last folder and you will be able to flash your phone with MIUI.
Once done verify everything is working fine, if it’s true, then reinstall /e/ last rom using their procedure.