[SOLVED] Registering for Push Notifications


I’ve successfully (it seems ;)) installed /e/ on my new FP3.
Now I wanted to use some message apps (Signal, Threema) and it seems that microg/GCM isn’t fully working.

When I go to the microg settings in the self-check everything is checked except for the UnifiedNIp/Geocoder, which shouldn’t matter here, I guess.
Device registriation is enabled and GCM is enabled as well, but says “Disconnected”. There are no apps listed using GCM.
Apps are allowed to register without asking for it (but tried either way, didn’t change things).

Now I’ve searched a bit on the forum and through the internet and there seem to be quite a few topics similar, but I couldn’t find a solution that changed things for me yet.

I’ve installed the push notification tester and it tells me that:

  • Play Services are installed
  • Internet connectivity is there
  • Connection to server is there
  • but can’t register for push notifications

Since I’ve out of ideas myself, is there anyone who can help me getting this working? :slight_smile:



I think I got it working by dialing (I didn’t get at first that you really need to dial that by tapping the numbers) that ##CHECKIN## code. Threema already registered, but Signal so far refuses to.

Solved it myself. :wink:

Hi Berniyh, could you please give me a hint, how to convince threema and telegram to cooperate with microG? I can’t find the trick…
Thank you.

For Threema I didn’t really do a thing. Maybe a reboot, not sure. It did apparently check again for microg and started working.

For Telegram you have to ensure that you’re not using Telegram-FOSS since that has GCM-support removed. Telegram or Telegram X will do.

1 Like

Okay, that seems to be my problem - I installed Telegram FOSS. I’ll replace this with Telegram - NO-FOSS. :wink:
But about Threema, I’m still sceptic. My microG shows for GCM: “Aktueller Zustand: nicht verbunden” (actual status: not connected). May this is the problem…

Install the push notification tester and see if it can register. (Can e.g. get it via aurora store, I don’t think it’s in the e store)

If that is not the case, try the checkin thing:

  1. Open up your phone app
  2. Enter the code shown in this message:
    Including the asteriks etc. Instead of the letters enter the corresponding numbers as indicated on your number pad
  3. Do the push notification tester thing again

If that doesn’t help yet, reboot and try the tester again.


Thank you - the magic dial did some good: the GCM shows “connected” and - voila! - incomming messages are notified. Such a strange dial - who would think about this cryptic stuff…
Thank you again and have a nice day!

Yeah, surprised me as well.

tbh, I thought I’d find such information here in some kind of tutorial or FAQ on this site, but couldn’t find it.

At least, in this thread now this essential Information is available.

My push notifications works without microG. But I think its eats more battery. Does mircroG require a google account?

How unique is the device identifier? Depends on the software installation? So new eOS installation == new identifier?

Without microg you won’t be using push notifications. In that case the apps build up a background connection, so it’s more like a pull (from your phone) rather than a push (from the server onto your phone).

You don’t need a google account to use the push notifications, but right now you need to use the google servers (via microg).

Your question about the device identifier I can’t answer unfortunately. Not that deep into the details of the implementation (yet).

There is a relatively new project (idea) looking into implementing a separate, self-hostable push system, namely openpush and the /e/ guys are interested, but it’s very early stages, so have to see and wait what’s going to happen there. See e.g.


1 Like

Thanks for the answer. :slight_smile:


Im trying to register element push notifications. I tried to download the “push notification tester” but there are two options and Im not sure wich one it is. Can you please give me a hint ?

ThreemaLibre for degoogled devices comes with an own push service. Using Google’s push services wouldn’t make any sense. See https://threema.ch/en/blog/posts/threema-libre

1 Like