[SOLVED] Samsung S7 data not working

I bought a preinstalled Samsung S7 to support this great initiatibve after trying itfirst on an old phone. But I now find, that I no longer have data on my phone and I have no idea why.

I have a data plan for 8 GB a month, which is more than I ever used. I have Data roaming on and checked LTE as preferred networktype. But when I check the simcardstatus of the phone, it says Network: Vodafone (now temporarily named VFNL #stayconnected), Roaming: no roaming, Status mobile network: connection lost. However, I can call and be called. Only my dataconnection is not working.

I tried resetting the network, but no succes. The build date is january 6, by the way. IS there an newer version. It seems, that is checked, but this is rather old. Build-number: lineage_herolte-userdebug 7.1.2 NJH47F20200106 dev-keys.

Does anyone have any idea what can be wrong?
I read this thread, but it didn’t help me:

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @langedarm, did you have this issue from the time you purchase the phone or did this happen after some time.

I’m not exactly sure, to be honest. I’ve had problems sometimes, especially when abroad, but I don’t use much data and in The Netherlands, there is almost always a wifi network availble, so I do not have a big need for data. But I noticed that I don’t get messages on my Signal app when there is no wifi. It seems that the problem is not consistent, on and off so tot say. But I found that for the last month it hasn’t worked at all.

1 Like

It would be interesting to know if the /e/ for herolte “dev” (nougat) produces the same issues as /e/ version “stable”.

My issue with mobile data when I first roamed with /e/ was a wrong APN. I know you read the quoted How To article but can you check those settings again? (Settings > Network & Internet > Mobile network > Advanced > Access point names). Is the correct (ie your service provider’s) APN selected? In my case I had to change from Tesco (which had come from I have no idea where) to Vodafone.

To get more info from your phone you can dial *#*#4636#*#*, then “Phone information”.
Also, it could be a network provider problem, have you checked their support ?

Thnx reb77, but that is not the problem.

Smu44, that is a very interesting trick. When I dail it I get the following info (literally translated from Dutch):

Current network: VFNL #stayconnected (which is a stupid name Vodafone changed it network name in to show they care about the Coronacrisis)
“Speakingservice”: in use
Dataservice: connection disabled
Type “speakingnetwork”: LTE
Type datanetwork: LTE
Roaming: No Roaming
Preferred networktype: lte/umts auto (PRL)

I do have dataroaming enabled andthe apn is live.vodafone.com, whick is correct

I really don’t know how this is possible.

I’ve tried by disabling manually network data, “Data service” displays “Disconnected”.
So your status “connection disabled” may indicate that your provider has disabled data …
Do you have access to an online account management at Vodafone ?

FYI my phone is a Xiaomi MiMix2 on Sosh (Orange) french network

Yes I do and I already checked that several times. I don’t think it has anything to do with my provider. Must be something on the phone

I can now definetely confirm that the phone data works sometimes and sometimes it does not. I really haven’t got a clue what’s wrong.

You could do a test with LinageOS 16.0 and 17.1 builds for comparison. Both LOS versions work well with Team Win Twrp Recovery twrp-3.3.1-0-herolte.

Hi there. My problem is still unsolved and it seems that I can not send signal messages or use Firefox at all anymore when I don’t have wifi. It’s not a problem with my provider. My mail (I uuse K-9) works fine and I noticed that I can use my phone as a wifi hotspot and use firefox and Signal on my tabled via the wifi hotspot of my phone, so I must have working data right? All I can think of is that it’s a flaw in the operating system that makes firefox and Signal not working or that some safety issieu prevents the programs to acces data. Does anyone have te same problems?

Hi there. Does nobody have the same problems? It’s becoming more and more irritating. I didn’t really mind for a while because I mostly had wifi werever I went, but especially in the summer that has not been the case and non working Signal is really becomming annoying. It’s a preinstalled Samsung S7 I purchased from the e foundation, so I owuld expect it to work properly. Alas, that is not the case. Although I really want to support e because we must make a stand against google and other techcompanies who think our data is theirs to use, I am more and more tempted to go back to them because the inconvenience is becoming a major irritation.

hi, there,
I finally remenberred my login for the forum. An update for this thread. I asked my provider for a new simcard, since it was very old and voila, data was working again, but abroad it still didn’t And when I got bakc to my own country for some reason data was not working anymore again. Now I tropped my sweet S7 in the water and although I took it out within a second and it is suppost to be water resistant, after I turned it off and back on again it got stuck on a strange download screen. Guess I’ll have to buy me a new one :thinking: :frowning_face:.

Hi there,
The S7 was not broken by the drop in the water, but this issue with no data still remains. After I asked for a new simcard with my provider (Vodafone in the Netherlands) the problem seemed solved, but every time I visit another country or try to use data in an area where I have no 4G, the dataproblem reappears. in Others phones the simcard works perfectly, but in my S7 with E os it doesn’t. I think that every time a 4G connection can’t be made, some setting in the E os is changed, thus preventing $G from then om, but all the settings I can see/change are correct (network type LTE, roaming checked, APN live.vodafone.com. The only strange thing I find is that when I go to "about the phone/simcard status/roaming it says “no roaming” although I have dataroaming enabled and “status mobile network” is “disconnected”. “My Phonenumber” says “unknown” although I can make phonecalls and The vodaphone icon is visible at the top of the phonescreen. When I disconnect wifi, the icon changes however and a small x is visible next to the intensity of the signal sign.
I really haven’t got any idea what could be wrong. I don’t think it’s broken hardware because when I put in a brand newe sim card it works untill the first time I go abroad.
When I dial *#*#4636#*#*, then “Phone information” I get the info that is in the attached screenshots. You can see that “dataservice” is disconnected (“verbinding verbroken” in Dutch) and “roaming” status is “geen ( no) roaming”.
I would greatly appreciate help here. Thanx in advance.


Have you tapped on LTE/UMTS auto (PRL)
to open the list of standards avialable ?
you could find another combination that is better for your needs

1 Like

“no roaming” may come from the capabilities encoded in your SIM card …

Please try as @piero stated, using “global” at first.
Also, you may be offered a band choice from the 3-dot menu within info screen (try Automatic and Europe at first).

Piero and SMU, thnx foor your help.
I tried changing preferred network type. When I changed it to LTE/CDMA/UMTS auto (PRL), I noticed that “data service” (gegevensservice in Dutch) changed from disconnected tot connected so I expected things to work again. Alas,
When I try to set the band choice from the 3-dot menu within info screen to Europe (or any other option) I get the message: “Setting [Europe] failed”. “Global” is not an option I can choose here.
When I scroll down in the Phoneinfo screen, I find a setting “refreshingfrequency of mobile data” and it’s set to “disabled”. Does that have anything to do with it? I tried setting it to “Immediate”, but it didn’t seem to help.When I restart my phone this setting is back on disabled and the preferred networktypesetting is also back to LTE/UMTS auto (PRL).

I googled (via startpage) for problems with dataconnection and Vodafone and found a thread in a Vodafone forum in which the correct settings for the APN: live.vodafone.com were explained. Mine were different so I changed them and voilá, it works. apearantly these settings are automatically changed when I go abroad and that is really annoying, but at least now I know what to do. I saved the correct setting om my phone. I hope these setting work outside Holland as well.
Guys, thnx for helping.