[SOLVED] Uber on /e/ Android 8.1.0

I had /e/ on a Motorola G4 Play (harpia) and I could install Uber without issue, set it up and run (both normal version and lite version), the normal version had a problem with the map display but was working fine.

Now I got a Samsung S9+ (bought directly from /e/ foundation) with /e/ and even though I can install both Uber apps, none can be setup, the normal Uber version displays a message of “Please check connection” after I enter my phone number and then keeps restarting, while the lite version goes as far as sending me the confirmation SMS and ask for the account password, and after that it goes back to the original button of “Get started” and won’t go further.

Did anyone experienced this? Any suggestion on how to fix it?

I am running:
/e/OS: 0.7-2019110830012
Uber: 4.278.10002 (50005)
Uber lite: 1.56.10003 (424)

Both Uber apps were installed via the /e/ Apps application.


I have read first time that uber app was working with e-OS.

I.know a lot of people which gave tried. The telegram group is full of posts og uber app fail. I’m allway answer to use the uber pwa https://pwa-directory.appspot.com/pwas/5728656530341888

On.which e-OS version was uber working ?

Version I have on the Motorola is: 0.7-2019111931239
But the version I originally installed the Uber was from a few months ago, can’t say exactly which one.

Ok, so I upgraded the Uber apps to the latest versions using Aurora store and it just worked, maybe it was just a case of App store from /e/ not having the latest version?

Current working versions are:
Uber: 4.290.10004
Uber lite: 1.78.10001

Yes, the apps in apps store are often not the newest. Sadly.:frowning:

Are you on nougat, oreo or pie ?

Oreo, as far as I know there’s no /e/ pie version for Samsung S9+

Thx for information that uber works on Oreo.

Can confirm that Uber works on Moto G4 Play (harpia), but I haven’t been able to use Uber Lite. Actually, can’t confirm the last three updates (don’t use Uber too much, except when I travel), but haven’t had a problem with it before.