[SOLVED] Unable to enable encryption

Hi guys,
Just installed /e/ on my galaxy s9, looks super nice so far. However, I have a problem. When choosing encrypt this phone, not much happens. Is this fuctionality not there yet? I just want to double check so that i don’t set everything up just to having to factory reset after that feature is implemented :slight_smile:

1 Like

I have the same issue, my phone reboots and then nothing.

Welcome @iYbMtWiCdC
You cannot encrypt while phone is rooted. The functionality is there, yes.
Can you shut down (power off) the phone? I had this issue last year, on another device.

I managed to figure this out. It is an issue with the partition table of the data partition. When I formatted it with trwp before installing /e/ it uses all the blocks. The encryption in oreo requires 16 bytes of unpartitioned space (or more) at the end of the data partition for it’s encryption headers.

I saw a solution requiring shrinking it with cli tools, however, i booted into trwp and choosed wipe -> advanced, clicked data partition and then resize. After that little trick I retried the encryption and now it works fine!


I confirm, this works, thanks!
In TWRP, it’s a bit odd how the resize happens, because I was expecting TWRP to ask me to enter the new size manually, however, everything has worked automatically :slight_smile:
My /e/ S9 is now encrypted.

Do you guys know, the SD card gets encrypted too when enabling phone encryption?

Did you configure the SD card as “internal storage”?
AFAIK it’s encrypted when configured as internal storage and it’s not encrypted when configured as portable storage.