[SOLVED] Unable to Install /e/ rom Xiaomi Mi A1 tissot


I have a brand new Xiaomi Mi A1 (tissot). I followed the instructions on how to install the roms ( I used all the available roms from the site)

I checked the SHA256sum after I downloaded the roms and they match.

Still I have the same error to all the roms

I tried the lineage-15.1-20181222-nightly-tissot-signed.zip and it successfully installed the rom.

Can you provide old version of the rom for me to test?


@spg i have uploaded an older version of /e/'s official build here
See if that build is working for you and do let us know.

Looping @rhunault on the thread.

1 Like


Should I downgrade to version 7.0 or 8.0 is fine?

We do not have nougat builds for /e/. This build was on Oreo. Also wanted to know what is the stock ROM build date on your miA1.


See the screenshot below


Ok thanks. Just wanted to check since i read somewhere that Xiaomi is planning to implement Anti roll back on MiA1 to prevent return from Pie to Oreo https://gadgets.ndtv.com/mobiles/news/xiaomi-explains-why-it-no-longer-allows-mi-a1-mi-a2-and-mi-a2-lite-users-to-roll-back-from-android-p-1965198. Since you have an oreo build that should not be the issue. Let me know once you have tried flashing the old build

1 Like


Encountered same error.

Do you have any idea about the error “kDownloadPayloadPubKeyVerificationError” ?

I search the net but no result found.

Update: Okay this is weird. I’m currently in Slot A when trying to install the ROM. After I encountered the error again, out of curiosity I tried to reboot to Slot B. Lo and behold, it boots up to /e/ ROM. I’m currently downloading the latest nightly build.

Is there an explanation about this.

Wow! That is interesting! @rhunault could this have to do with the A/B partitions in MiA1. The build is trying to install on the same partition and maybe failing giving an error. When @spg changed the partition it worked. Never seen this error before.


Here’s my theory, the ROM is trying to install to both A and B. It successfully install to B but failed to A.

The point of having A/B partitions was that the install would happen to the non -active partition. The advantage being that in case the install fails the existing active partition with the working build continues working. In normal phone without A/B this would result in a bricked phone.

Does it mean it tries to install to Slot B when the phone is currently in Slot A? If yes, does it mean the error I encountered is in the Slot B?

Another Update: I tried to boot to Slot A and Slot B. Both of them able to boot to /e/ ROM. Interestingly, the latest update is in Slot A which 0.2-201812222301 while in Slot B the version is the ROM I tried to install which @Manoj provided (0.2-201811222069).

@spg at present which version is running on your phone?


The phone is currently in Slot A system version: 0.2-20181222301

That is the current version of /e/ for tissot. You can now delete the older versions. The future updates will be coming OTA.


The older version 0.2-201811222069 is in Slot B. I need to boot to Slot B in order for me to delete the old rom. I’ll just leave as it is as of the moment.

Thanks for the help