[SOLVED] Unable to install Gapps after removing /e/ rom

I needed to create an account. I need help.

I have flashed an unofficial /e/ rom through TWRP, and used it normally (no issues), however, something very odd happened when I tried to remove the rom later.
I flashed an unnoficial version from this thread and user

I’ll explain deeply what happened…
I’ve bought a new phone and decided to give this one to my mom, before doing it I decided to backup all my data… No problem yet.
My mom needs Google stuff (it means, Gapps installed) and I won’t force her to use /e/ rom or something else, so I booted up to TWRP (recovery) and wiped: dalvik / ART cache, cache, data, internal storage and system before flashing a new rom.

I decided to flash normal LineageOS 16.0, I downloaded the correct gapps packages from opengapps (as I always did before using /e/), then I flashed LineageOS rom followed by Gapps and rebooted as always did.
I noticed it took a huge time to boot up (it has never happened), when I booted I noticed only LineageOS was flashed, the gapps wasn’t… It was not asking for Google account, etc, as it normally happens when you flashes gapps. No Google Play, no gapps at all. Even though it was flashed through TWRP.

Then I tried 10 times, battery went from 100% to 10% very quickly… Needed to charge the battery to keeping trying… No surprise. The 10 times I tried, no success. I’m unable to flash Gapps… for some unknown reason.

So I decided to flash only the LineageOS, reboot, make all the configs and then reboot to recovery trying to install gapps separately… Well, it flashed normally (no errors), however, it was stuck for 10 minutes on LineageOS boot animation and then it rebooted directly to TWRP (recovery) after trying to install Gapps. What’s wrong?

I have tried to install LineageOS+Gapps on other versions of TWRP, no success! The problems persists…
I have tried other roms (I thought it was something related to LineageOS), no success! All other roms refuses to flash Gapps, even though it says it has flashed with no errors.

After some research I think the problem is related to some configuration on /e/ that blocks Gapps or blocks you from fully remove the rom (maybe for security purposes?!). Maybe it was encrypted and I tried to wipe out everything and this happened? Maybe there are still something that was not wiped out blocking me to install Gapps?!

After a lot of different attempts to install Lineage, TWRP started to glitch and notified an error message while trying to wipe partitions. The error is “unable to mount storage”… I followed a lot of instructions to get rid of the error, it worked for some time when the error comes back. I don’t know if this is related to the removal of /e/ rom.
For the error, this tutorial worked better.

Since I have removed /e/ a lot of issues have happened blocking from installing Gapps (even on other roms). Isn’t it suspicious? I think the phone is fully bricked now. I don’t know what to do.

I think your issue doesn’t have to do with e-OS.

the best solution is, if the device is bricked now, flashing original stock rom. And than start over with LOS.

1 Like

@Walpur, there’s a couple of bits missing from your post. Such as device and Android version of your previous /e/OS. Was it also Pie? If not that would explain a few things. Otherwise, not sure. Since you’ve done full wipes, including internal storage, it’s safe to say /e/ has nothing to do with what’s going on.

Have you checked any of the logs? TWRP’s recovery log (saved from its Advanced menu) and/or the logs generated by opengapps?
Agree with the above. Go with a flashable stock firmware or fastboot flash original firmware. Either may fix things up.

Could also be that its a A/B partition device. What phone is it? Regardless it sounds like you need to flash back to original firmware/rom and start again, not an issue with /e/.

It was gapps. There was an issue, now fixed. Download the latest version.

So can you pls change the headline of your first post to [SOLVED] …