[SOLVED] Updating Xiaomi Mi A1 impossible (0.2-201901182691)

I tried to install the update 0.2-201901182691 on my Xiaomi Mi A1. Something went wrong. Downloading the file is no problem. First step of installing is also no problem. However than updating stops when starting “Die Paketinstallation wird abgeschlossen”. Its german and I think in english it means “Update to be finished”.
Have anyone an idea?

Can you try to download the file to your PC and then flash it using TWRP. I had the same problem with the OTA build for MiA1. Flashing the ROM updated it.

An issue has been raised for this on Gitlab https://gitlab.e.foundation/e/os/LineageOTA/issues/5

Good morning Manoj,
thank you for helping.

I don’t know if I understand you right. I will do the following steps.

  1. Download the file from this site: https://images.ecloud.global/nightly/tissot/
  2. Load the newest TWRP (1. adb reboot bootloader 2. fastboot boot twrp-x.x.x-x-tissot.img 3. reboot into TWRP)
  3. Install the file without “Format Data” and “Wipe Cache and System” (adb push filename.zip /sdcard/)

My settings and data will be available after flashing, right?

Always keep a backup ready. I do a clean flash just to be sure there is nothing of the previous build on the phone. The issue on OTA for MiA1 is not resolved as yet. I tested with yesterday’s build and it was not working OTA. Had raised the bug accordingly.

Ok, " I do a clean flash just to be sure there is nothing of the…" means that my settings and my data disappears?
I don’t know exactly how I have to do a manuell update with TWRP. Is there a tutorial available?
I think the best/easyest way for me would be to wait for the next update.

Thx for helping!

The install instructions for tissot MiA1 are here https://gitlab.e.foundation/e/wiki/en/wikis/device/tissot/install

@Liporello a resolution for the OTA issue for MiA1 is given here https://gitlab.e.foundation/e/wiki/en/wikis/fix-ota-issue-tissot

1 Like

It works fine for me :slight_smile:
Thx a lot!

1 Like