[SOLVED] Xiaomi Mi Mix 2 - Chiron - Not able to flash recovery in bootloader mode

Since some time I am not able to flash a new recovery or boot image in bootloader mode.

How to produce the problem:

  1. adb reboot bootloader
  2. fastboot devices (respons with device number)
  3. fastboot flash recovery recovery.img
    → Computer does not give any respons. The command line stays empty and stays there for hours.


  1. adb reboot bootloader
  2. fastboot devices (respons given)
  3. fastboot boot recovery.img
    → Command line gives no respons (no errors, no warnings or whatsoever).


  1. Xiaomi flash tool (which actually uses fastboot commands I believe).
    → Flash starts, but hangs there for hours without respons (also no errors or warnings).

Did this exercise on a Linux laptop, but also on a Windows 10 laptop. Both give exact the same results.
USB debugging is switched on.

I ended up in this situation, since I wanted to test /e/OS R-release and also wanted to use the e-Rovery tool. So, I decided to enable that option. That was successful, since erecovery was indeed flashed along with the ROM (flashed the ROM via TWRP (TWRP 3.3.1-1).

By using adb sideload, decided to flash the stock ROM of Chiron (miui_MIMIX2Global_V12.0.1.0.PDEMIXM_64006b3102_9.0.zip), which also went fine. The original recovery of Xiaomi came together with the updated stock ROM.

So, now I have a complete stock version of my Mix 2 available. But cannot flash anything else anymore. What are my option to flash back the latest /e/OS release? From bootloader cannot flash nor boot to a new recovery.

Did you apply for Xiaomi unlock again ?
Since you device already has been unlocked, it shouldn’t take long :wink:

Inside the developer options I see that bootloader is unlocked. Also during startup I see the unlock symbol. Does it need to be reapplied?

If you see the unlock symbol it should be unlocked, so the answer is no.
But you can try it to confirm :wink:

Also, did you try another USB cable ?

I did a quick check on the LineageOS wiki perhaps check out this recent commit devices: Stop recommending outdated TWRP images · LineageOS/lineage_wiki@72f3f95 · GitHub.

Used indeed more than one cable. It made no difference.

Downloaded the unlock tool from Xiaomi and tried to re-apply. Interesting outcome.
At first it was trying to read the device info. The Serial-Number (SN) was recognized. The message from the tool: “Read failed, please refresh or reboot device”. When rebooted it could not read out the device anymore, even not the SN. After several times of re-trying, sometimes it gave back the same message. Sometimes not recognized at all.

There seems to be something corrupt. After searching I found maybe something that could be related: GitHub - Maxpnl/Xiaomi-Unlocker-Fake-Fastboot. Going to give that a try.

@aibd , I am back to the stock recovery, so I guess not related to an outdated TWRP image. See also my previous reply to @smu44 . I guess something corrupt.

I do take your point, did you already use this exact MIUI already?

My experience is that increasingly newer MIUI make breaking into MIUI more difficult than 12 months ago. I am not being definite about this but perhaps worth checking out some recent posts on XDA

I am using this device for years. Just recently found out that flashing via bootloader does not work anymore. For sure it worked about one year ago.

1 Like

Unfortunately, I makes me think to an USB or adb problem, hopefully not an hardware problem :frowning:

If your Windows computers are USB 3, could you please try :

@echo off
reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags\18D1D00D0100" /v "osvc" /t REG_BINARY /d "0000" /f
reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags\18D1D00D0100" /v "SkipContainerIdQuery" /t REG_BINARY /d "01000000" /f
reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags\18D1D00D0100" /v "SkipBOSDescriptorQuery" /t REG_BINARY /d "01000000" /f


As an /e/ R tester I have to flash my chiron to stock (same image as yours).
I’ll keep you posted about the result, so we could compare.

1 Like

Moved your suggested lines into a “.bat” file and executed it as administrator. Next restarted into the bootloader and flashed the recovery. Worked at the first command! Now back to e/OS/!

Thanks a lot for your help, Sylvain! Great help.

1 Like

Nice to read that ! :slight_smile:

BTW no problem with my chiron when flashing the MIUI then /e/ R test ROM.

OMG, U ARE GOD, Thx so much! it’s helps for me!!!

You’re welcome, happy it also worked for you :slight_smile:

Original XDA thread : [Guide] Fix "press any key to shutdown" when unlock bootloader or run fastboot cmd | XDA Forums