Some apps won't connect to Internet on Wifi/mobile data; network connectivity problems

Hello, I am experiencing severe problems with Internet (both mobile data and Wi-Fi) and mobile network connections on FairPhone 4 with the newest /e/ OS.

I noticed that some apps have no Internet access, while others have. Once Telegram and Whatsapp do not work. I turn off and turn on the phone - Telegram starts working, and Wikipedia stops. Another time the browser or one or another e-mail app. Another time all at once. Or the network connection suddenly disappears, so text messages don’t come in and calling doesn’t work (at the same time it usually works when the Internet doesn’t work in one app and it works in another). Until I won’t notice it and turn off and on the phone, I will get messages about missed calls. If an app doesn’t work, it doesn’t matter if I connect WiFi or not (it doesn’t work over either mobile data or WiFi), although on other devices WiFi works perfectly.

What should I do? This makes the phone unusable. Also, if I transfer the SIM card to another phone, everything works perfectly.

Hello,
I’m sorry, I can’t help you.
I’m using /e/OS 2.1-t-20240603406607-stable-FP4.
Every thing works perfectly for me. I don’t use WhatsApp nor Telegram but Mastodon and signal.
Could this problem be linked to these applications?
I hope that other people who use these applications will be able to answer your questions, because my experience can’t be of much help to you…

It might be worth first to try

Settings > System > Reset options > Reset Wi-Fi, mobile & Bluetooth

I doubt that the problem is connected directly to any particular application, as I am discovering many new ones that have no Internet connection and usually regain it after I turn off and on the phone one or two times (and when they regain it, some other app usually loses it). Today Shazam and ProtonMail. Another time some other privacy-friendly e-mails.

I remember I have already done it in the past at least one time and it didn’t help. Well, I may do it once again, but is there any other way?

Hi @sppc

Do you use another DNS resolver server or from your ISP?
If another, which one do you use ?
Have you configure IPv4 and v6 addresses resolvers servers ?

Others devices on your network home don’t have this trouble?

Can you try these tests:

Wifi test

  • Turn off Wifi and Mobile data connection
  • Turn on Airplane mode → Wait 5 seconds → turn off
  • Turn on Wifi
  • on Settings → About Phone → in IP addresses
    What IPs addresses you have?
  • On browser in private mode, go to https://ip.lafibre.info
  • What are results, do you have IPv4 and IPv6?

Mobile test

  • Turn off Wifi
  • Turn on Airplane mode → Wait 5 seconds → turn off
  • Turn on Mobile Data connection
  • on Settings → About Phone → in IP addresses
    What IPs addresses you have?
  • On browser in private mode, go to https://ip.lafibre.info
  • What are results, do you have IPv4 and IPv6?

It can be difficult to troubleshoot an issue as you report it. Perhaps you could try some of these to see what might have a bearing on your issue.

Does your carrier offer 5G, are you using it. If yes you might experiment with switching it off from Settings > Network and internet > Mobile (carrier) > Preferred network type.

It is difficult to stay in Safe mode for an extended period; but you might try as long as possible. Press Power off button > Long press Power off icon > Select Safe mode.

This might help to identify if some third party app is responsible.

Looking at this possibility, now out of Safe mode, try Swipe down (as if to open notifications etc) and swipe down again. Do you see “Active apps”, any surprises there?

A setting which might help to separate whether mobile or Wi-Fi as the culprit is apparently only available with Developer options on [1]. Settings > System > Developer options > Mobile data always active.

If Wi-Fi is problematic, is it home Wi-Fi or all Wi-Fi (assuming you can test a few Wi-Fi).

Possibly relevant; what settings are you using in Advanced Privacy. Any change when you switch off all or some.

[1] If Developer options are not available; Settings > About Phone > Build Number or Version > Tap seven times on Build number > You will get a message that you are a Developer.

Apologies @dj0, I did not see that you had replied while I was writing!