Some problem installing /e/

support

#1

Hi there !

I tried yesterday to install /e/ on a samsung galaxy s7. I first flashed TWRP with odin , then I followed the instructions “Installing /e/ from custom recovery”.

However , it seems that it didnt work, because when I rebooted my phone, I had all the samsung and google apps …

How is that possible ?

In the instructions it was mentionned "Note: Be sure to reboot into recovery immediately after having installed the custom recovery. Otherwise the custom recovery will be overwritten and the device will reboot (appearing as though your custom recovery failed to install). "

I didn’t reboot into recovery immediatly , and I had an error message “no command” while I was trying to reboot into recovery. However after few seconds I was into recovery because I had the black screen and all the recovery commands …
I don’t know if it could explain why it didnt work …

Should I do it all again from the beginning ? Is there any risk ?

Thank you very much !!

edit :
I understand now that I have never been in TWRP recovery mode but android recovery mode …
I was trying to download TWRP with Odin but it didnt work …
Now I am trying to follow these instructions https://gitlab.e.foundation/e/wiki/en/wikis/device/herolte/install
But in step 7 my device doesnt reboot. I have this message “ERROR: Failed to send data!Releasing device interface.”
I tried to replace again my usb driver as explained in step 5 but now I have en error message “the driver installation failed”


#2

“No command” is the start screen of the standard recovery, so since you didn’t reboot into TWRP the standard recovery reinstalled itself.
Just try again and this time don’t forget to reboot into TWRP.

There is always some risk, but I don’t think it will increase if you already failed once.


#3

Allright ! Thank you very much, it’s a really usefull answer !

I’ll try not to fail this time !,


#4

@PaulaFairphone Actually I just downloaded TWRP on my phone, but now I dont know how to reboot.
I am holding volume up, home and power at the same time, but nothing is happening…


#5

I don’t have any experience with flashing Samsung phones so I can’t tell you anything except whats in the guide.
Are you sure you followed it step by step? There is a whole section about preparing the phone before installing a custom recovery, which is not necessary on my phone.


#6

Ok no problem :slight_smile:

Actually, I followed an other tutorial which was different but it didnt seem to work on my phone …


#7

I have finally been able to boot into TWRP recovery mode.
I thought I did the right things but now I have a boot loop …


#8

You can try to wipe data, that sometimes helps. Boot into TWRP, then Wipe > advanced wipe, select data and then wipe. I assume you have nothing important on the phone yet, because this wipes all your app data, etc.


#9

Thank you for your answer ! I am going to try that. But after it should I reboot ?
And do all the instructions all over again ?

And no, no important data , only the phone is important :slight_smile:


#10

No just erase data, then reboot and see what happens.


#11

Unfortunately, it’s not working :frowning:


#12

What do you see when booting, do you see the e logo?


#13

No because I have never been to this step … I havent install e yet.
Just TWRP and something called dm-verity because I followed some instructions for samsung mentionning it. I thought I would install e after that, maybe I understood things wrong.

Shoud I try to install e now maybe ?


#14

Yes, e must be installed “seperate”.


#15

ok I am installing it right now. Fingers crossed !


#16

yeaaayyy !! So happy, I am seeing e for the first time :heart:

Thank you so much :slight_smile: I was actually really close to it …


#17

Your welcome, you were almost there indeed. This stuff is quite confusing if you do this for the first time, I’ve been there. Have fun with /e/.


#18

Yes it was totally confusing I had no idea what I was doing :laughing:

Thank you again :slight_smile: