Sony XA2 [H4113] - USB OTG not working [SOLVED / closed]


I tried to read some external memories with my device, but I discovered that any of them were detected / read.
It seemed strange to me, since I used the same method when I installed /e/OS on the device … and I used exactly the same equipment (a cable USB C to USB A, a memory stick).
Therefore, I tried another cable, memory stick, I even tested SD cards with a different adapter, but nothing changed …
I checked the settings, and found “Developer options > Select USB Configuration”. I changed from “Charging” to “MTP (Media Transfer Protocol)”, rebooted, but nothing … it seems that the device does not detect anything connected to the USB port …

Any ideas?

Thank you in advance

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

My Sony will only read my USB drive if the connector is inserted a certain way (seam side facing the same direction as the screen). You might try turning the connector 180 degrees and see if it is read that way.

I had not noticed that before… but I will try.

thank you @Taurus


Just some feedback after trials (with different USB C to A adapters, memory sticks and SD cards).
Everything worked fine, without needed to adjust any settings. I could read the memory sticks and the SD cards.
Just a comment fro @Taurus : I tested the USB C connexion both sides, and in both ways I could read the memory sticks / SD cards (which is nice, although it was not so obvious, after thinking about your comment). So I do not understand what was wrong when I did the test some days ago …

By the way, I noticed the following: although ejecting the USB device before physically removing it, sometimes the device froze / rebooted … my conclusion is that it is not a good idea to repeatedly remove / swap USB memory sticks / turn the adapters upside down and so on … it seems the device does not appreciate it :slight_smile: . It should not be a big issue, since the real usage would be connecting only a memory stick, manage some files, and finaly eject it.

I will mark the thread as [Solved], since it seems now OK (although it is still not clear to me why it did not work few days ago … )

The metal USB-C connector end that inserts into the device has a faintly visible seam on one of the long sides. For my phone, I have to insert the connector with that seam facing the same direction as the phone’s screen, otherwise it won’t be available for file transfer. If I insert it with the seam facing the back of the phone, it doesn’t mount correctly. Could just be a quirk of my USB drive.

I haven’t experienced any of the problems you mentioned regarding safely removing/ejecting the USB drive.

Glad you got everything working, though. :+1:

1 Like

I understand, that’s why I tested (because, when I had used it to install /e/OS, I had experience no issue, and it is seems unlikely that I was so lucky to plug it the right way every time :smile: ). And it is a reason why I consider strange (and fortunate) that it works both sides, since USB C is symmetrical (and they made it smart enough to work in both ways), but on the other end, I have a USB A connector, which is not symmetrical at all … my conclusion (disclaimer: I know nothing about hardware :grin: ) is that USB C was developed in a very smart way

Now, everything seems ok, therefore, thank you again for your replies.