Sony XA2 with Android 9: Warning


Andy suggestions about what I should do next?

Thank you in advance

Did you try another PC?

No, I have only one available …
Do you really think it could be the PC ? Do you mean something wrong with the installation of adb / fastboot?
Personally I believe something went wrong after the installation, as I could end all the steps of the procedure …

I download sony flash tool (“Emma”) and what I could understand from it (and from some search in Internet), I can update my device to the latest patch from Sony issued in December 2018 and based on Android Pie… I do not know if that means that it had Pie before or that all the devices connected to Emma are to be update to Pie regardeless of what they had before …

If I understood andrelam correctly, I should run the following commands:

fastboot devices
fastboot boot “lineageOS.img”

then I should have lineage OS installed… and from that, reinstall /e/ ?

PS: volume down is for Emma, volume up for fastboot

Hi again,

sorry for insisting, but it is not clear to me if I should first recover the original Android Pie with Emma, then install Lineage OS and then move to /e/ … can anybody confirm, please?

Thank you in advance

Hi Sony, I had some issues with getting /e/ on my XA2 (model H4113) as well.
I have gone back to the sony image 2 times which helps to get a clean startingpoint.
So yes, I’d recommend to use Emma to go back. Which images does it offer you?

Also, whether ADB or Fastboot work depends on your drivers which can be a pain.
In the end, I only needed Fastboot to work to start TWRP. Then I wiped per instructions and I skipped the sideload steps. Instead, I put the e…zip on a SD card and installed the zip in TWRP. Worked like a charm.

PS Where are you living?


Thank you for your feedback. In the end, I used Emma, see the following for the details:

so you suggest a micro SD … I can try that, but I guess that was not the problem when I tried to install (everything ran fine until I went to TWRP and after wiping, the question was about A/B …)

The link you provided is dead.

I am flashing again with Emma … so the issue with the procedure is the step 7 of the paragraph "Installing /e/ from custom recovery "
I thought that Recovery meant the Recovery button in TWRP … can you please let me know how to go to Recovery mode and then move to the next steps ? Or, if it is easier, how to go on with a micro SD?

Thank you very much in advance

When you are “in” TWRP you are in recovery mode. Goto Advanced > sideload or something similar :grinning:

Thank you for your reply. I will try again …

[Although it is off - topic:
even if I understand that /e/ is in beta phase, and if I clearly lack knowledge about the smartphone tools needed and the flashing procedures, I feel that there is still a tough entry barrier to people that are interested / would like to test /e/ but they are not skilled enough, since the installation procedure (at least for Sony XA2) is not clear and simple enough for the less advanced user to follow … and this could really prevent /e/ from spreading … for instance, I would not suggest trying /e/ to my friends, since it would not be straightforward enough for them to install it, despite the fact that I recognize that support is offered by other users through the forum (and I would like to thank all those that has spent some time to help me out)
End of off-topic]

I agree, for some users it is a bridge too far. There are some ideas for flashing stations, but that is not concrete yet (read here)

Hi @sonyxa2 we do have an easy installer tool under development. It will be a CLI tool but will make it a lot easy for users to flash the ROM. Agree with you that flashing a ROM is not exactly easy for all - even the 'expert’s have to be careful and not skip steps or they could end up bricking their phones.

yeah, I had read it, let’s see how it develops


I repeated the process and stopped at the step 6 of the procedure “Installing /e/ from custom recovery” = I wiped, and copied the zip file of /e/ image to an USB pen drive (and installed with a USB C adapter; it works :slight_smile: ) . Therefore I skipped all the part with adb sideload and I appreciated it a lot, because (after an endless wait) it worked! I chose to reboot after installation, at the end of the installation I received a scary message (“no OS installed, are you sure you want to reboot?”) but after confirmation, the phone rebooted and an /e/ appeared.

Nice. Now I have to set it up, the first message I got was that the calendar stopped (ok… we will see later), and that Bliss Launcher in not allowed as Apps with usage access (I am not sure what that means)

But I am quite glad that I can see /e/ on the phone, therefore let me thank CK.Roji for his tip, and thank all the other people that helped me as well.

[Although I think it will not my last question / post (I have a lot of things to learn…)]


Glad to hear you finally got /e/ booting on your XA2 :smile_cat: :+1:

I tried and installed the more recent version of /e/ on a Sony XA2 on Android 9.
Since I struggled a bit to get it working, let me write down here the few steps it requested.
First I tried the official tutorial but to no avail : it kept rebooting for a while then stopped with a message saying the device was corrupted and it would power off in five seconds.
Then I decided to re-flash the XA2 with an Android 8 ROM, using Emma (Sony flashing tool). Then I followed the tutorial and somehow got the same result : device rebooting etc. Except that I coud see rather quickly a message in color, and not all of it (its right part being beyond the end of the screen) :
“Can’t load Android system. Your data may <…>
continue to get this message, you may ne<…>
factory data reset and erase all user da<…>
Underneath, one could read “Try again” in blue and “Factory data reset”.

I decided then to give Lineage OS a try : everything went smoothly. I then tried and installed Lineage OS for microG : I got the same annoying message except it was displayed a few seconds, which allowed me opt for “Factory data reset”. Then it finally rebooted normally.

In the end I decided to go back to /e/ and, knowing where to put the finger, I managed to choose “Factory data reset” in a fraction of second (after four attempts…). Then it rebooted to /e/.

To sum it up :

  • first go back to Android 8 ;
  • even if you wiped, re-wiped your device, you still need to re-re-wipe it after the installation.

It would be nice to have the “Can’t load Android system.<…>” message for several seconds, allowing to choose the factory reset option easily.

Thanks for the following posts, which helped me. And I hope mine will help someone as well.

@bompi Thanks for your report. Which version of Emma did you use?

Emma’s version :
It seems the last SONY ROM I flashed is :
50.1.A.13.123 (Customized_UK 1312-3737 R20A)
The Oreo version is probably the more recent and was chosen by Emma.

This is similar to my experience, detailed elsewhere here; I got the “device corrupted, power off in 5 seconds” spiel, too. It seems that a ROM re-flash or two might be necessary. Or perhaps, it was because slot A was not formally specified.

There may be some need to re-work the documentation for this phone series. I am unwilling to go back and blow away the hard-earned set-up I’ve (finally) managed to get going on my phone. But there are some issues with the steps as well as the drivers (also detailed elsewhere here).