Sony Xperia Xa2 Howto Question

Hi !

I try to understand your Install Howto for Sony Xperia Xa2:

You write:

My Question: 
From where do it get this image ? I dont understand what to do this point. Is it this TWRP - Thing ?

TWRP is a custom recovery image. It’s a powerful tool that can do many things and therefore needs handling with care and attention. In this case (on the XA2) it is used to perform some wiping steps followed by helping to flash the eOS.

There is a link to TWRP on the install instructions. twrp-3.4.0-1-pioneer.img works well.

Your device should be on android 8 to install the dev version of eOS (which is linked to in the install instructions)

ahhh ok. thank you. i did the how-to and it worked “well” till the last point: reboot system.
I see th sony logo, and afterwards the screens turns black and thats it. does not seem to work, i try to reset cache and/or reflash. wish me luck.

hm well, i think i broke it.
Cant boot into recovery mode or fastboot anymore. instead of the blue light i get a green one.
I think i flashed the .img falsely to the boot “folder” instead recovery folder. The how-to is not clear enough cause:

but then at the bottom of the site in an hidden field its explained how to fix this error with adding a new folder named “recovery”.

I tried to flash it to recovery, as its written. it did not work, cause i did not had the folder on my device. but then i saw this “on some devices…” and the “OR”, so i flashed it to “boot”. :frowning:

When it was too late, i found the troubleshooting section.

Did i killed it ? i just bought it for 90 euro, just to install /e/ :frowning:

So you managed to boot twrp and sideload eOS but it hung at the black screen. What eOS zip are you trying to install? Is it ?

What android version was the phone on before you started?

Unlikely. But it might be in a bit of a mess; don’t worry, it should be ok.

Trying to decipher your comments. Looks like you’re now trying to boot twrp again to start over. Was the last command you entered fastboot flash boot twrp-3.4.0-1-pioneer.img?

Can you get recovery by unplugging phone, power off, then press power+vol down until it starts with one vibration?

My Answers:

Yes, i booted twrp and sideloaded the OS file wich worked (ok on windows shell and ok at mobile display). Then i restarted and since then nothing happens after sony screen (white), display stays on for some seconds, then it switches off.

Yes, e-0.14-o-2021012798648-dev-pioneer is the release i tried to flash

The Os before was Android 8.0 (Oreo)

I’ll try to fix it, yes this was the last command.

If i press vol+ and power it shows an green light for an second, then it vibrates once, then 3 times a little bit longer

If i pres vol- and power it starts with the “bootloader” screen, then sony white screen, then black screen. (nothing else)

At PC its an MTP Device. Battery should be fully loaded.

The forum is littered with people having problems with version 0.14 updates and installations so you may have more luck with e-0.13-0-.

You’re on Android 8, so that’s good.

Pressing and holding vol+ and power (as you have noticed) will prompt 1 vibe followed shortly by 3 quick vibes. If you release the buttons after the single vibe this is for start the device. If you keep holding buttons in after 1 vibe, and release after the 3 vibes: this is for power off. Useful if phone is in a state where you can’t power down normally on power button alone; in a bootloop for example.

You’ve tried to manual boot recovery and it looks like it can’t find anything. Can you get into fastboot mode by plugging in/holding vol+ ?

nothing happens with vol- and pluggin in :frowning:

Oh, right. This is unusual.
Have you tried a few times to manually get recovery up? Remember to release vol-/pwr buttons at vibration.
Assuming it goes black screen after Sony screen, plug in to PC, open terminal in your folder , and try entering adb devices.
Long shot. Just possible its in recovery but screen off.

Also, have you got another cable to try.
And plug direct to motherboard , back of pc

Vol up, plug in for fastboot

i tried it 10+ times.
vol+ and cable = nothing
vol- and cable = nothing

Mobile is shown as MTB-USB-DEVICE in windows Devicelist

C:…\Xa2\twrp>adb reboot bootloader

  • daemon not running. starting it now on port 5037 *
  • daemon started successfully *
    error: device ‘(null)’ not found

fastboot devices
is empty

adb devices
is emtpy

cable is directly plugged into backside of the PC, i tried usb 2 and usb 3. i tried different cables too.

more and more i think its broken…:frowning:

Sounds bad and I can’t think of anything else. You would at least need the Sony flashmode, vol down- plug PC, green led, to reflash stock.

yes, sounds bad.
Id thought fastboot turns the led blue ?
Maybe the batterie wont charge, the red light goes out after some seconds.
If i had an hot air fan i would open the case to take it from power, this sometimes fixes problems.

I guess the only possibillity is to flash it directly to the EEprom on the motherboard, but i dont have the technical stuff needed or the software to do that. I dont have any other idea to access this “boot” section, i think thats the problem.

Well, i think its dead :frowning:

But, thanks for your help. Next time i directly buy an /e/ mobile intead of flashing it by myselfe.

yes, fastboot mode, vol up and connect usb=blue led

flashmode, vol down and connect usb=green led. This for reinstalling stock rom with Sony’s emma or newflasher.

Sometimes the phone can recover itself a bit if it’s left untouched overnight. But it sounds like a hardware problem with yours. Clutching at straws here but maybe try charging it for a few hours (even if no led’s showing) and then let it rest a few hours.

I wish someone else could offer some bright ideas to help you.