Sony xperia xa2 with unbootable message

I’ve brouth a sony xperia 2 and I’ve tried to install /e/
So now when I turn on the phone there is this message ”Your device is corrupt. It can’t be truster and will not boot. Your device will be powered off in 5 seconds.”
I’ve tried with Sony Companion but it doesn’t Work.
Help me please.
Tank you

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi SebOs

What steps for installation have you taken so far?
Have you done the (mandatory) step “copy” in adb?


I tried adb and twrp but I think I’ve erased all programs… I haven’t access to the smartphone


What OS do you use for flashing? Try differnt USB-ports on your PC and/or with USB-hub also. Different USB-cables you can also try…
I made the experience that only a USB 2-cable works for me (OpenSuse Tumbleweed).

Please try a battery-reset: phone off, Volume up + power until 3 vibrations.
Are you able to put your XA2 in Fastboot-mode (phone off, press Volume up, plug usb-cable, wait for blue LED)? If yes, your XA2 isn´t dead. The XA2 can take an eyeful, it is really robust, i own two of them, both flashed 6 times minimum with different OSes.
I also had this message you mentioned above one time. I don´t believe your XA2 is dead :grin:

Do you know the EMMA tool ( for Windows) from Sony? With it is easy to flash Stock ROM.

So please try in this order: battery-reset, fastboot mode, try to flash TWRP or /e/- recovery… What are the results?


Hi Maschinengeist
For flashing I’m using linuxmint 20.1 ulyssa
I’ve tried with different usb port and Usb cables… no result
there is 3 vibrations when volume up+power and the blue led is blue…
So I’m lost to install /e/, I think it’s very difficult for me…
I can’t install EMMA on my LinnuxMint, there is a problem when I try.
I don’t have a windows PC… only one old IMac…and my linuxmint laptop.
When I try ADB to install twrp there’s no device found…
I hope I’ll find a solution.
thanks for your help

AS Machinegeist says, the XA2 can take a lot of flashing punishmnet. I’ve flashed them countless times with all sorts of stuff and got into many messy states in the past. So don’t worry, you will get it going eventually if it was running ok before you started this.

Are you trying to install eOS R btw?

The main thing at the moment is to get a recovery booted on the phone. Put the phone in fastboot mode by plugging into laptop while holding volume up and wait for blue led.

If that works ok try flashing the latest e-recovery
fastboot flash boot recovery-e-0.21-r-20220125158734-dev-pioneer.img

(Or use twrp if you prefer, just change the command)

If the terminal output shows the step has completed, unplug phone (which is powering off) and manually boot the recovery by holding power and volume down; release power button when you feel the vibration.
This should boot up the recovery.

If you need to return to stock android 9 you can do this on Linux by setting up Xperifirm for the Sony firmware download which can then be installed using Newflasher. It can be a learning curve to set it all up but it’s a great way to return xa2 to stock.

Hi SebOs

One question by the way, because it was never mentioned: is the Bootloader unlocked? :upside_down_face:
(keep in mind that for unlocking procedure there must be a valid SIM inserted and mobile data connection active).

SebOs, i know it´s an eyeful but i think you´re only one step apart of getting it on your XA2, please hang on :+1:

@chrisrg xperifirm and newflasher, thanks for the hint! :smiley:

Greetings, Maschinengeist

Hi and thank you for your help
I’ll try it as soon as possible because I’m at work for 2 big days.

The Bootloader of my XA2 is unlocked.
Thank you so much for your help,
I’m at work for 2 days

I try a lot of solutions but when I want to use ADB there;s this message : adb reboot bootloader
error: no devices/emulators found
I’m so lost


Hi Sebos,we can help you here if you help us to uderstand what’s going on and answer these questions!

So, was device on android 9 before starting this?

Did you get to the sideloading eOS stage on your first go?

Are you trying to install the latest eOS-R?

Is your phone still unbootable with the red warning?

Are you actually following the install instructions for e?

I’m guessing you are in fastboot mode when you issue the command adb reboot bootloader , yes? That won’t work because you are in fastboot mode.

My phone was on Androïd 8 at the begining
I had problems to install twrp.
I read instructions and I was trying to install Eos Q before R
my phone is always start with red warning and power off untill 5 seconds.
I just want to save my phone with Androïd or /e/ but I really prefer/ e/
adb reboot doesn’t work when is on USB.


You’ll get it working, don’t worry about that; but you might have a bit of work to do.

Your phone needs to be on android 9 before installing eOS-q or -r. If you install either of these eOS’s they may boot up but it is almost guaranteed you will have some network problems because of not having the latest android updates. We can deal with this later…

Did you manage to boot twrp on your first go? Did you boot twrp and then sideload eOS or did your problems all come at the “installing” of twrp stage? It would be good to know this please.

With the phone powered off and not plugged in can you boot a recovery by pressing power and vol down: release power on vibration but keep holding vol down. If you get erecovery, do a factory reset and then reboot and see what happens.

I think you need to plan to install stock android 9 fairly soon, but it wouldn’t harm to practice with an e install first!

What do you think @Maschinengeist , others…?

twrp doesn’t work when i’ve installed on my phone

No idea what you’re doing.
Installation instructions for e are good.
All the information for a resolution is above.

Install stock android and start again.

I’ll try to install android 8… And I’ll see.

Android 9 is required.

A vague memory comment: I saw that message at one point also. I think I had to re-flash back to Sony’s image with Sony’s own Flash tool and then go from there.


Hi SebOs

Do you use the device specific TWRP, this: twrp-3.6.0_9-0-pioneer.img? This is which i used…
I would suggest to flash Stock ROM for XA2, first method with EMMA-Tool from Sony (Windows, select, this is Android 9, it must be 9).
This works, i can confirm, used myself.

Second is with “Xperifirm” (download stock ROM) and “newflasher” (flash onto phone), both Linux. Download worked, but flashing did not work (was my fault, have not unpacked it before flashing).

Please try:

  • flash Stock ROM
  • flash twrp-3.6.0_9-0-pioneer.img on your XA2
  • flash /e/ OS, from SD-card or as adb sideload


Hi I managed to reinstall Android but it is android 8 which is installed initially now I'm looking to relock the xperia to be able to switch to Android 9 I will try your method
I succeeded because I had my daughter's Windows pc, with a mac or a linux I can't do it there is always a problem, especially on linux with sony usb compatibility.
 thank you Sincerely