Sony Xperia Z5 Compact

Hi @Unknown,
I tried to build on my own with the script you refer to
but the script stopped:
rsync: chown “/srv/src/NOUGAT/.repo/local_manifests/.” failed: Operation not permitted (1)
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1196) [sender=3.1.2]
[Sun Oct 20 12:19:03 UTC 2019] Use branch cm-14.1 on
[Sun Oct 20 12:19:04 UTC 2019] Syncing branch repository
sed: can’t read build/core/ No such file or directory
sed: can’t read build/core/ No such file or directory
sed: can’t read build/core/ No such file or directory
[Sun Oct 20 12:19:05 UTC 2019] Can’t detect the android version
Do you have an idea?

i need more details, like what your build script, full logfile,are you build on your pc or server?

I build on a pc with Ubuntu 18.04.
I tried with and without docker.
I used the script you refer to on the community, the “easiest way”. I have enough space.
I replaced v1-nougat or v1-oreo and suzuran.
The first time without docker syncing worked until 20G. I had to stop it. Then I tried again and the error occurs.
Tomorrow I will upload the logfile.

suzuran only have nougat sources

sudo docker run \
-v "/srv/e/src:/srv/src:delegated" \
-v "/srv/e/zips:/srv/zips:delegated" \
-v "/srv/e/logs:/srv/logs:delegated" \
-v "/srv/e/ccache:/srv/ccache:delegated" \
-e "BRANCH_NAME=v1-nougat" \
-e "DEVICE_LIST=suzuran" \
-e "CUSTOM_PACKAGES='MuPDF GmsCore GsfProxy FakeStore Mail BlissLauncher BlissIconPack MozillaNlpBackend OpenWeatherMapWeatherProvider AccountManager MagicEarth OpenCamera eDrive Weather Notes Tasks NominatimNlpBackend Light DroidGuard OpenKeychain Message Browser BrowserWebView Apps LibreOfficeViewer'" \
-e "SIGNATURE_SPOOFING=restricted" \
-e "OTA_URL=" \
-e "REPO=" \

Hi @Unknown,
I had no time for building suzuran on my own for some months.
Now as there are OTA updates for the supported phones I am interested in an update for suzuran again. But with my equipment it does not work. Perhaps because the main hd space is too small and I try to link to a mounted device. I don’t have the time to continue testing.
So I would like to ask you @Unknown again to build me an update (newer than 0.7 of september).
I would be very glad if you could do that for me.
Thank you in advance.

Done, check androidfilehost.

1 Like

Thanks! Your build works fine for the suzuran as usual.

Hi @Unknown, would you please create me a new update for suzuran?
Thanx in advance.

Hi @ulionetouch and @Unknown - I am also running /e/OS on a Sony Xperia Z5 compact! It’s running fine, and I would also love to upgrade the build for my phone if possible!
Looking forward to it!
Cheers, SOLUSfiddler

Hi @ulionetouch (and @Unknown)
Thanks for your efforts on building for the z5 Compact
I’m working up the courage to install /e/ on my phone, but I’m nervous about losing functionality. Both Camera and WLAN are mentioned earlier in the thread as problems. How are these working in the latest unofficial build?
Thanks again

Hi Pete!

I’m using that latest unofficial build without problems, although the Z5 Compact is not my main phone.

Camera and wifi work without a glitch as far as I have tested it.

Sometimes the Aurora store (logged in as anonymous) doesn’t get synchronised or updated so I have to log out and back in again, the Apps store by /e/ is crap and doesn’t get curated well but there are always workarounds available for these little problems and the community is very active and - at least here in Germany - very helpful.

Give it a go!


Hi, the Apps store has received a major update, but of course you need a newer build. Maybe it will fix some of the issues you faced.

Thanks for replying!

Yes, I know that the fact I’m running my Z5C on an unofficial build of /e/ might be the reason I’m still fighting with a bad version of Apps.

But I have heard from a lot of users (German forum) they also experienced that.

Maybe one of these days there’ll be an official build… :grin:



Hi altogether,
I had to finish using my suzuran. The battery looses complete energy within less than an hour. So I refunctioned the z5C to a web cam. The build I need now is for a

Sony Xperia XZ1C

Thank you in advance if someone creates one for me.


Oh no, I still need it for my Z5C…


I’m using it now. Downloaded and installed this morning. Just finished setting it up with all my apps :slight_smile:

I plan to investigate making builds, but that’s for later!

Do we have any idea what’s been added since the latest build by @Unknown in January?

By the way, I also have an old Z1c that I run LineageOS on, works fine and I will sell it soon, together with the magnetic charger dock and a bumper.

You want to have it?


Today I managed to build an unofficial ROM. I’ve installed and run it on my Z5 Compact. If anyone else wants to give it a try, let me know and I’ll upload it somewhere. No warranties, and at your own risk!

For information, my run command was

 docker run \
  -v "/srv/e/src:/srv/src" \
  -v "/srv/e/zips:/srv/zips" \
  -v "/srv/e/logs:/srv/logs" \
  -v "/srv/e/ccache:/srv/ccache" \
  -e "BRANCH_NAME=v1-nougat" \
  -e "DEVICE=suzuran" \
  -e "SIGNATURE_SPOOFING=restricted" \
  -e "REPO=" \