Sony xz2 compact: No sound in call since 1.8.1

Dear e/os’ers

Device: Sony XZ2 compact

Very fond of this project, and have been using it for a year without any problems.
However since the latest 1.8 update (1.8.1) I lost the ability to have sound in calls (phone/whatassp/signal)

  • sound/audio in calls works if I use speaker
  • microphone works (record sound item and play works)

What did I try?

  • full reset of app preferences in 1.8.1
  • full format and clean install of 1.9

Any ideas? This really seems like a software issue.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

The app Fairphone Checkup is adapted to work on most / all devices. This offers the opportunity to run a check on both speakers.

Thanks for the feedback @aibd. The test “ear speaker” fails. I cannot hear any music while performing this test. Would it be a hardware or firmware issue? I personally doubt this because the failure came exactly with the 1.8.1 update

I once had the same problem. This worked for me: [UNOFFICIAL BUILD] Sony Xperia XZ1 Compact (lilac) e-1.3-q Post #212 - #210 by Taurus

If you don’t have an XMPP account loaded, you might try SIP instead. If neither, just try: power down, remove the SIM card, power up, attempt to use the dialer (won’t go anywhere, of course), power down, reinsert SIM, power up. Then check functionality.

You might also try doing a temporary test/switch with a different SIM, if you have one lying around, even if it’s an inactive SIM.

Another thing to try:
Open the dialer, go to its settings screen, select Calls, then Calling Accounts, and then (re-)select the account used for making calls.

Have you tried using a different phone app? Simple Dialer from F-Droid solved some problems with earlier versions of /e/'s Phone app

Thanks for the feedback. I really appreciate this. You guys are awesome.

I tried the following suggestions:

  • shutdown phone, remove sim, start phone again, tried to call, shutdown phone and re-enter sim
  • I did the same procedure as above but re-entered the sim in the second sim slot
  • I re-selected the calling account in dialer settings.
  • I used the simple dialer app instead of the standard e/os dialer app.

However regretfully It did not solve my issue. Any suggestions on which XMPP client I would best try? Also is there like a test address/dummy contact somewhere? I do not have any friends nor people I know on XMPP.

Btw is there a build.prop parameter I can add or toggle? I have found (a rather old) topic about LineageOS where they talked about the setting “”. However I cannot find that setting in my build.prop

I use the service, which requires a (cheap) subscription. In return, you get a US or Canada number capable of communicating by voice with any other number. This is combined with messaging (text and picture) over XMPP to/from any other number, and is also able to receive 2FA codes from most commercial entities. JMP ( recommend their fork of the Conversations app “cheogram” (available on F-Droid, or that other store) to organize everything in one place (messages, top-ups, account info, support, etc.), but you can use another XMPP client if you want. Calling is handled by integrating with the phone’s dialer app (hence my reference to the calling accounts settings, above).

But if you have or can find a cheap VOIP service, and add it as a SIP dialing account, I suspect that my suggestion about the calling accounts reset will work by toggling that, as well. (In other words, I think the key is to temporarily force a different phone number in the settings.)

You might also see if you can force the dialer to ask you which account you want to use for calling every time you initiate a call. (I’m not sure if that will work if you only have one calling account.)

Thanks for the feedback Taurus. I got hold of another sim , a data only sim, but on on another provider/number/calling account. Still the same issue (tried the procedure above)
Still doubting to get a sip subscription since I do not want to waste any money if the ear speaker is really dead

This would not have the ability to make calls, though, right?

Understood. (They’re very cheap, though, and you can always cancel afterward.)

Know anyone with a VOIP account who might be willing to help you test your phone?

It’s possible that one of the “free telephone number” services out there might also work, if they use the integrated dialer. Might want to do a quick search for that.

I’m guessing it’s probably not dead. (And you indicated sound works for other applications, right?)

As an example, there is a cheap VOIP option here, from Callcentric.

The plan is “Pay Per Call.”

  • Outbound only (unless you also add an incoming plan, which will incur a setup fee, a monthly fee, and an assigned phone number; see second table)
  • $0 setup fee for outbound
  • Load minimum $5 in account
  • $1.50/month for mandatory e911
  • Pay per minute ($0.0198/min for domestic U.S.)

Skimming around in various forums, I see multiple threads about call audio issues with Pie/LineageOS, affecting various phone models.

Here’s one:

Similar can be found at XDA Developers forum. (search “LineageOS no audio during calls” or something in that vein.

@Manoj, are the devs aware of an issue like this with the Pie builds? Is it maybe something that could be corrected centrally and pushed out with existing OTA updates for at least the official builds?

P.S. @sonydude, my XZ1 Compact just started malfunctioning again, too.

As you may know OS builds prior to Q ( Pie, Oreo, Nougat) are not supported any longer. Which is why developers will not prioritize any issues on those OS versions. If the issue is showing up on Q / R builds then it needs to be reported and an issue created if not already done.

Understood. I’m running Q on the Xperia XZ1 Compact, so I guess it’s time to report it. How to proceed?

You can raise an issue here . In case you have not created issues in Gitlab earlier you can follow this guide

1 Like

Thanks, @Manoj. I see someone has already created an issue about this:

I would just add that it appears to be a common issue mentioned in LineageOS forums, and is not confined to devices from one OEM, so I doubt that the suggestion to do a factory reset would accomplish anything. Also, there have been a couple of different threads in these forums reporting the same issue, involving different models.

The issue (no audio in earspeaker during calls, but audio fine through loudspeaker) with my Sony XZ1compact first occurred in earlier Q builds, and I once fixed it by making a call with an XMPP account. After that, the earspeaker worked again for a long time. Now the issue has returned with the latest OTA update (1.9), although I can’t say definitively if the update caused it, or some other action did. (And so far, my DIY fix is not working.)

Should these extra details be added to the existing issue?


Yes pl add details of your device and if possible attach a log. Remove any personal information from the log before attaching. I am sharing the issue information with the dev team to check.

1 Like

Oh well…

1 error prohibited this user from being saved:

  • Email is not allowed for sign-up. Please use your regular email address. Check with your administrator.*

You can check this guide for assistance with errors during ID creation

1 Like