Spell Check broken in eOS 0.21?

After an update to eOS 0.21 from the previous 0.20 on stable on Samsung S9 the spell checking behaves funky. It is happening on two phones of the same make.

System Language is set to English
ASOP keyboard is used.
Two other languages are installed (Czech and Russian)

  1. Regradless of the langugae on the keyboard the text fields treat everything as English so in Czech or Russian almost all text is underlined red, that does not help really.

  2. Not consitently but often enough even the suggestions in ASOP keyboard get messed up and switch to English although the selected language is not English.

Anybody else seeing this issue? Any tips what to try or how to fix it? It worked perfectly fine up until now and we started using eOS more then year ago.

I’m of not much help here as I do not use the spellchecker - but I forget to disable it (when switching keyboards it’s all underlined red). From looking at the settings, the selected system-language gets precedence on the spellcheck, not by selected keyboard-layout: AOSP Spell Check

Did this change from versions? Were you on 0.20-oreo stable and updated to 0.21-q, or did you stay in the same Android version (just updated /e/ version) ?

you could try other keyboards, a user as asking for this: spellcheck by selected keyboard-layout-language: Alternative keyboards for /e/?

Everything worked fine on 0.20-oreo and stopped working correctly on 0.21-q.

If I read it correctly it seems that 0.21-q ASOP ignores the keyboard layout looks like using an alternative keyboard is the workaround let me check. Thanks for the suggestion.

hm, I have a hard time finding an exact bug for this, but it must be one. In the Language settings of AOSP Keybard you can pin to either system-language, but also uncheck and select multiple other languages that are referenced in custom-input-styles. But switching has no effect. Maybe an AOSP Keyboard bug.

Choosing another keyboard App is probably the easiest solution. Swype, Swift, etc

Yeah, another keybord app is what I am trying, going with AnySoftKeyboard for now.

Later updates fixed the issue for me.

1 Like