AOSP Spell Check

I’m using eOS based on LOS 17.1. I use three different languages in keyboard for communication and I would love to have spell checker for each of them. Now Spell Check is dependent on the system language. So if I use a French system language it only checks french words. If I use an English it will check English words. I would need to check words based on the set keyboard (AOSP keyboard) layout not system language.
Is there a way of achieving that or is it a bug or maybe intentional “improvement”?


I don’t know if you can do this with the AOSP keyboard.
I use AnySoftKeyboard from F-Droid. If I switch between kezboard :wink: layouts for different languages, the spell checker also switches the language.
So if it really doesn’t work with AOSP, you can switch to AnySoftKeyboard.

Thanks Ijahn. I’m rather interested in AOSP keyboard and Spell Checker.

Hi Cooky,
Have you been using your phone for a long time? I use the AOSP keyboard with multiple languages. The spell checker worked fine until the last update (29 January). Now I encounter the problem you describe (and incidentally, I hardly ever type in English, which is my preferred system language…)

Hi Linda,

It depends which you mean by long time :slight_smile: I use AOSP keyboard for for more then a year. It was working fine on Nougat with eOS installed. Well, it was not great but at least enough for my needs. There wasn’t much options for customizing it. I found Open board at least better , but Spell Checker for check language didn’t work at and I stopped using it, cause it was quite crucial functionality for me. Now changed the phone and system to Q and this AOSP keyboard works even worse what is a bit sad to me. I’m not sure if it’s an issue of the Android system or eOS update by itself but I don’t want to waste my energy to active “dead” keyboard service maybe I’ll give another try to other keyboards which seems to be more “alive”.

By the way what is system that you use (Android version, etc.) ?

I’m on /e/OS Android 10. The spell checker worked fine until I installed the January update.

Okay, I got it. So I couldn’t noticed this change, cause I already started using January version of Q with eOS. Before I’ve been using Nougat with eOS.