SSL certificate not trusted

Hi all,

I got this warning when starting evolution, whose calender is synced with /e/ caidav calender. Shall I simply accept it and how do you generally deal with such an incident?

Hi @Mickey the team is looking into this. Will get back with a response ASAP

1 Like

The certificate is not yet expired, as all others involved in certification chain (Gandi, USERTrust).
Is your PC clock up to date ?

Thank you very much @Manoj!

@smu44 I determined this before but my clock time is set properly.

The certificates have not expired. The team had a look and responded that it is possible that there was a expired cert down the trust chain that got renewed a little too late - as our cert is not expired . The current expiry date is 6 Aug 2020. It might take a while to get this propagated globally. It is fixed meanwhile so the problem should go away even when users do not trusting it explicitly.

1 Like

There’s got to be something wrong with this as I’ve been having various apps complain about expired Ecloud certs and finally decided just the other day, like a day or 2 ago, to accept all expired certs. For my computer and phones. But today I see on another computer the same warning come up.

And then on my primary computer I decided to delete the ecloud account, now when I try to recreate it ---- see pics2020-06-05_12-13

HA! I think you’re confusing the dates. You say it expires Aug. 6 - 08/06/2020, but maybe this date is in European format? So it expired 8 May 2020, which makes sense!
Actually I see that I’m not right based on the following info in the cert:
|Not Valid Before:|2019-08-05|
|Not Valid After:|2020-08-05|
So it is valid till Aug 5, but why does everything I own disagrees?

In your screenshot and in the original post, there is a Details button. Did either of you check that? As Manoj mentioned, the main certificate is not expired but one of the intermediate certs may be. Causing issues in other areas, too. Like a weak link in a chain.

Hi everyone,

apologies if we’ve taken a little longer to get this solved. We got some reports the day it expired but then no more and since browsers and eOS apps were working correctly we waited a bit to evaluate its real impact.

We have just deployed a new certificate in which is provided by Let’s Encrypt and doesn’t have the expired intermediate from Gandi/UserTrust. Ours didn’t expire until August, as Marc pointed out.

This article explains in detail and great clarity the problem, which basically was coming from a bug in OpenSSL and not the expired certificates.

Please confirm the problem is indeed gone and upgrade wherever possible the SSL/certificate packages of your system.

Kind regards,


Hi arnauvp, today when I tried to add the /e/ e-mail account to Windows 10 (latest version), I got the message that the certificate of is invalid.


this is a different issue I think. Please use and it should be OK. I will close this thread now.