Stellarium not working after app update

After updating via App Lounge from v1.11.0 to v1.11.1 Stellarium (com.noctuasoftware.stellarium_free) no longer works.

On opening the app a dialogue box appears asking to ensure that Play Store is installed. Closing this box closes the app.

I tried clearing cache & data, then uninstalled & reinstalled (after reboot) and the same issue was still there.

I’ve now reinstalled v1.11.0 (downloaded from apkpure) and this works as before.

Presumably the new version is attempting some sort of check with Play Store, although this had never been needed before for the free version.

I’d be grateful for any other ideas.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Stellarium appear to be up for receiving feedback !

How can we help you today?

1 Like

Thanks. Have just emailed them.

1 Like

Same here. I don’t use it to much, so I switched to the open-source app Skymaps.

Seems related to this post.

Confirmed. v1.11.1 runs without error with updated FakeStore.
I am not on so I do not know if the /e/OS v1.12.3 builds have the updated FakeStore.

No one mentioned what builds they are on.

1 Like

Thanks for this information, it’s good news that a fix is in hand.

I’m on a Fairphone 3+ running 1.11-s-20230510288098-stable-FP3. I’ve been holding off on updating to v1.12.3 because of the reported location issues.

Same here. Neither of my /e/ devices are on 1.12.3 due to latest microG.

I have a spare /e/ supported device I can use for testing. I’m tempted to install 1.12.3 but then try to replace microG with the previous 0.2.27. Maybe.

Stellarium works fine on my S7 with 1.12.3, no mods or else, simply updated OTA

com.noctuasoftware.stellarium_free Version 1.11.0
Installed from aurora store but updated by app lounge

I installed from AppLounge Stellarium_free version 1.11.1 and it seems to be running fine on 1.12.3-q-20230620301517-dev-a3xelte.

App Lounge Store is version 0.2.0-21g7af8bfe

1 Like

Ah, thanks for including that. Confirms that 1.12.3 includes the latest FakeStore. :+1:

1 Like

@obacht it was following the update to Stellarium v1.11.1 that it stopped working for me. Would be interested to know if that version works for you when / if you update.

I tried on my Xiaomi Lavender with

  • /e/ os v1.12.3 dev
  • com.noctuasoftware.stellarium_free
  • version 1.11.1

The only thing I can think of is that on my device (with appropriate modifications) I can pass the Safetynet test.

I hope this will help.


I just got Version 1.11.1 via aurora store and it seems to work well (I am not an expert user though, but the app starts as usual and does not freeze or the like)

1 Like

Update. I’ve now updated to /e/os v1.12.3 stable and done a fresh install of Stellarium 1.11.1 from App Lounge and it’s working fine. Thanks everyone for the help & feedback.

1 Like

I have the same problem with the v1.11.1 Stellarium (com.noctuasoftware.stellarium_free) on /e/OS 1.8.1 for Oneplus3.
A dialogue box appears asking to ensure that Play Store is installed.

Mentioned several posts up why that is and why it now works (with updated FakeStore included with /e/OS 1.12.3).

Yes, thanks marcdw, but i’m stuck with /e/OS 1.8.1

If you are still using Android 10(Q), you need to upgrade to Android 11(R) :

There is only 1 version of /e/OS in active development for each device.

As is my mata device, 1.8.1-q.

There is no FakeStore apk at the /e/ GitLab and upstream version cannot be used (signature mismatch - expected).
I saved/exported the apk from an updated /e/ device and installed it on 1.8.1.
Ran Stellarium again and it is good to go.
I can make the apk available if so desired.

Regarding the need to update builds. You do not need to do anything unless you have a need.
Latest OP3 is 1.11-r. Not the latest and, per this subject, still has the old FakeStore.

My mata, btw, has builds up to 1.13-s. Do not like or want A12. A11 is at same build as A10 so… I stay where I’m at.
Latest/greatest ≠ need.
Necessity = need.

1 Like

Ok marcdw :smiley:
I would like to download the apk if you can give me a link.