Storage problems with Samsung A5

I installed /e/ os on a Samsung Galaxy A5, and everything worked well for a while. However, internal storage space filled up quickly.

I bought a 128GB MicroSD card, installed it, and formatted it as internal storage. I migrated some stuff over, and I thought everything would be good. But soon enough, I got another message saying that my storage space was running low. Now, I’m seeing some strange behaviour.

New pictures are saved both to internal phone storage, and the SD card. If I delete the picture from one location, it is also deleted from the other.

I am trying to download a new update, but I can’t because the internal storage is full, even though I have room on the SD card. I removed a non-essential app, but storage filled up quickly again. I deleted some pictures, but for some reason, that didn’t change the phone internal storage, only the storage used on the SD card. I was sure to delete the pictures from the phone internal storage.

When I connect it to my computer, I can only see the SD card storage, not the internal phone storage.

I’m not sure what else to do. It’s some really strange behaviour, and I don’t know how to fix it.

Has anyone dealt with this, and/or knows how to fix it?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @winch and welcome.

I had all of the above with a Samsung A3, where I had initially installed the card to mimic internal storage. I found a further problem that Thunar on my Linux laptop complained.

I got an OTG drive and saved my stuff. I then asked the phone to format the SD card as regular external storage (warning of loss of data). No real attempt to format was made by the device, but the SD card was returned to external use.

After a bit more irregular behaviour I used my PC to format the SD card (FAT 32). This was not a full fix. In the end I formatted the SD card on the device with TWRP. I was never quite sure if some of my difficulties were user error at some point! :slight_smile:

How did you format the SD card with TWRP? Did you do it through Wipe > Advanced Wipe? Or through Mount?

I used Wipe > Advanced wipe.

There is no guarantee thst is a full format. I still have issues that feel a bit like the SD card does not mount correctly 100% with Camera and Save to SD card, but then so do many people.

There may be mileage in learning a better way to format an SD card, but I never got round to it.

Thanks. That seems to work. New pics and videos are being saved to the SD card, which solves the problem.
For some reason, now when I go into my storage settings, I don’t have an accurate representation of storage amounts. Example: In my SD card, it says I have 15GB of stored apps, and 0.0GB of Images, but I know that’s incorrect. The majority of the 15GB are actually images. But I’ll take it. The original problems I was having are solved.
Thanks for the help!

1 Like