Stuck at Odin, but never tried to download anything yet

I am trying to set up /e/ on a newly obtained Samsung Galaxy S4 mini (GT-I9195) serranoltexx.

Following /e/ documentation, I have issued the commands

adb reboot bootloader

“to enable OEM Unlock through the command line”, which I believe is the necessary first step before flashing the ROM.

Now the phone is stuck at Odin for 20 minutes already, displaying “Downloading… Do not turn off target !!”. I suppose it won’t end up successfully, after all I haven’t provided it with any ROM or boot loader.

What should I do?

Have you tried this?

Steps to enable OEM Unlock through the Developer Options

Settings > Additional Settings > Developer Options > Search for OEM Unlock and enable

On some devices the path may be as under

Settings » System » Developer options » Search for OEM Unlock and enable

Cannot find this option on my stock Samsung firmware.

There is “Developer Options” (under Settings » More tab) but no “OEM Unlock”.

Turns out I could just proceed at installing a custom recovery… Go figure.

S4 mini LTE is my favorite device !
i use /e/ on it since more than 2 years.
Internal memory size could be a limitation in a near future.
CPU and RAM are ok for the moment.

It doesn’t exist on android 4 !

Just go to next step

1 Like


What ROM are you using?
I have just noticed that the official /e/ ROMs for S4 mini LTE have not been build since the end of 2020, for whatever reason. Unlike the ones for the dual-SIM version, which I have been using previously. Bummer.

You are referring to e-0.13-n
We have an issue openned on the /e/gitlab

I liked e-0.9-p from @Chimpthepimp that was fully working.
Now, I use e-0.18-r from @itsclarence with SimpleDialer app as a workaround to make the incomingCalls catchable.

[UNOFFICIAL BUILD] e-0.18-r (Red_velvet_cake/android_11_based) for Galaxy s4mini LTE (serranoltexx) GT-I9195

1 Like