Stuck on fastboot flashing unlock(Now Black screen)

If I had a GigasetGS290 with a black screen in any of the modes I would do a Hard Reset. (I might try Soft Reset first just to check the effect.) I checked the manual, and (in a short search) found no reference to Soft Reset or Hard reset. The manual says for information further to that in the manual you are to contact their support service, in your country, seems to be available online or by telephone.

If the black screen is in say the Fastboot mode only I would assume I could use Factory Reset from within the phone and the Utility modes would all come good.

When I search online I find this, How To Hard Reset GIGASET GS290? and Factory reset Gigaset GS290.

Update When I asked at Gigaset Service portal about Soft Reset I received this reply:

You have asked us how to do a soft reset on this model, first of all, you should remove the SIM card and SD card before resetting.

Also, we recommend you to back up your data beforehand, as all memory contents will be deleted.

In order to reset the phone, please follow next steps:
"Settings > System Settings > Backup & Reset.
and select “Reset to factory defaults”.
Or (depending on the software version)
Select Settings > System > Reset options > Delete all data (factory reset). > Restart phone.

We hope that you find this information helpful and useful regarding your inquiry, if not, please contact us back and we would be more than happy to provide additional information.

Will one of the above options work for you?

@Chris375 The main thing your log is telling us is 12 instances of

Could not open serial device

Easy Installer v0.12.1-beta tried many options, but in some way the device was not actually in the mode that it was expecting. :slight_smile:

Will one of the methods above allow you to recover the phone?


just recived my GS290, tried to install e with the easy installer. Followed every step carefully. At the end I waited really long for the phone to turn on again.
Never happed, its dead! Black screen, doesnt react to any pressed key, no reaction if connected to power, PC doesnt recognize it anymore.

Any hope that I can restore the phone? Would really appreciate any help.
Cheers Wilm

Hi Wilm, welcome. Did you first report this on Telegram? :smiley:

From what you say, your phone will be fine, do not worry about that.

no i did not. Should I?
Cheers Wilm

Absolutely no need to report on Telegram!

I just gave advice to another with the same problem. : :smiley:

Did you see the current Gigaset / Easy Installer warning here?

Do not worry. Let’s see if we can get a log to start with.

And let’s reset your phone by one of the methods above.

I read the warning after the problem occured. Just saw gs290 listed on supported devices and thought itsfine.

I used „easy installer“ on Ubuntu 20.04

Found 2 Log files here are the links

Thanks a lot for your help!

Great, what operating system is on you computer? Edit, sorry, you said Ubuntu 20.04

I used Ubuntu 20.04 Gnome 3.36.8, I also have windows10

you have a choice of 2 operating systems, that is good!

Let’s deal with one only, to start with! :slight_smile: I see your first log on Linux.

Did you recover the phone yet?

No. I will give it a try with SP Flash Tool. But i have no expirience with recovering or flashin phones.
What would you recommend?

I suggest you do a Factory Reset first, do you see the suggestions immediately above?

we find this issue difficult to advise at first hit, but you have been brave and set yourself up as an “Experienced tester” - stay cool. :wink:

If you get a chance to take a PC screenshot, or photo of your device, that will be extremely helpful to anyone reading along.

you mean this?

I cant acces my phone, its like dead.

Exactly that. It seems dead, but it seems to have switched mode in some way. Gently try each of those suggestions. Please don’t go beyond what seems sensible to you.

Thanks for the info.
I tried the hard reset, as there is no running OS necessary.
The phone doesnt react to any keys pressed, I tried all combinations.

I am going to step back for a bit.

It is a mystery to me why one of the resets does not work.

Did you try Volume Up + Power for over 12 seconds?

These are the instructions for a manual install. I suggest it is worth reflecting on them, to see if it throws light on where Easy Installer went wrong.

Please log what you do, on this thread, so that others can help you.

Yes I tried.
When I connect the Phone to my windows Pc , It says for a few seconds „mediatek android device „, thats the only sign of life i get from the phone.

I do not want to guess what is happening. It will be solved. Did you notice the version of Android on your GS290, before you started?