Stuck on fastboot mode, cant enter recovery or eOs

Please help me!

My main problem was to get the SecureGo-app running. After I followed a possible error a FP-angel suggested, I am now stuck in fastboot mode. I just executed the command fastboot flashing lock and all I see is fastboot mode with options I can select but Im always redirected to fastbood screen. What can I do, is my custom ROM still on my partition or is the internal memory wiped out? And why cant I reach TWRP? It looks like my phone is completely wiped out.
(Here you can follow my way: SecureGo gives notice about my phone being jailbreaked - but it isnt - #5 by steviexo)

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

if it is a A/B slot device, try to switch to other slot
like it is said in documentation

I changed the slot and tried to start the phone to boot into system but nothings changed.
By documentation you mean which?

In the meantime I found a way to unlock the bootloader (by following this Fairphone 3 unlocking without oem unlocking - Development - Fairphone Community Forum) but this also changed nothing

Do you mean the alternative way to unlock the bootloader didn’t unlock the bootloader?
fastboot flashing unlock doesn’t work?

Or does the phone in fastboot mode say the device is unlocked now?
If so, just reinstall /e/OS. When you locked the bootloader before, you confirmed a factory reset, wiping Internal Storage for security reasons. The OS should still be there, but if you can’t boot it, it’s no use I guess.

Yes, it says its unlocked and the command fastboot flashing unlock didnt work, yes.
Thanks for that helpful notice, now I know which step to do - reinstall /e/OS.

I tried to reinstall /e/, following the official documentation, everything went smooth, no error occured but: when I tried to start the system I still encounter the same issue. No system, no recovery. Honestly, Im desperate now, please tell me what to do :frowning:

What does fastboot getvar current-slot say now?

It says INVALID :frowning: thats not good, right?

Not good, but can happen.
According to the install instructions the OS was flashed to both slots.

Just try fastboot --set-active=a and fastboot reboot.

If the phone doesn’t boot successfully, try fastboot --set-active=b and fastboot reboot.

If the phone doesn’t boot successfully there either, I seem to remember LineageOS had a script to really synchronise the contents of slot A and B with all the partitions not flashed when installing /e/OS in case something in that department was odd. To be found here (as referenced in LineageOS install guides).

Unfortunately, in both cases I end up in some kind of bootloop: first the message that my device cant be checked for corruption, then the message that it is corrupt and will poweroff. Oh, this pisses me off

What are the exact messages? There’s a message where you just have to press the power button to continue booting. This can be disabled via ADB later.

If you get a selection of trying again or a factory reset when booting, choose the factory reset.

I tried to press the power button on both messages, at the second one (where it told me that my device is corrupt and will poweroff in 30secs) it went into the black background with the FP-logo but nothing else happens

Not the desired end result, but at least the phone tries to boot.
With the current slot apparently valid again the recovery should be bootable again. Can you boot into recovery by keeping Vol + pressed while starting or rebooting the phone?
Keeping the power button pressed for about 15 seconds should force a reboot in any situation.

If so, you can perform a factory reset via the recovery and see whether that helps to push the boot process over the line.

And there’s still the LineageOS script I linked to above.

And if all else fails, you could also try to reinstall Fairphone OS to get all partitions of the phone properly flashed to have a well-defined default state to try to install /e/OS from again …

I did, still couldnt enter recovery mode. Seems like there is no recovery.

Ok, Im trying this now - though Im so tired but I want that fixed asap. Thank you for being with me at this late hour!

Could you tell me what to do with this? Sorry, Im new to this tech-world

Hmmm … I notice it’s not referenced anymore in the LineageOS FP3 install guide, but it’s still there elsewhere … it’s universal stuff not bound to one exact device, instructions are here for instance at “Ensuring all firmware partitions are consistent”.

Anyway … For now I would advise to proceed with installing Fairphone OS, it’s more failsafe I think and should also do what the LineageOS script does, and I can’t go on for much longer today, sorry.

If the annoying boot warning screen prevails, the command to disable it would be adb disable-verity, once the OS is up and running again and ADB is properly set up.

Sorry, yesterday I couldnt send you this answer because I was told I reached my max messages for one day, I hope this is no problem anymore because they updated my trust level.
Youve been such a great help, thanks for sharing your knowledge with me.
So, I installed FP OS which went well and the system booted, then I tried to install /e/ manually (the easy-installer wont start on Windows because I use a 32bit, did not knew that this is an issue for the installer) and also ended up in the Fairphone-logo-screen where nothing further happens

As I did not know how to proceed I thought I try to install TWRP: I followed their installation documentation until the Preferred Installation Method which said can not find ramdisk files so I followed the alternate method, which seemed to work fine, then I wanted to execute the recovery bootloop fix via TWRP which ended in an error 1 failed to patch kernel and now Im back to the issue that only fastboot mode is available, not even the FP-logo-screen shows up when I try to start the system. Ooooh, I never experienced such a bullshit with my FP!

You could just boot it with fastboot so you can use it for the task at hand (but only with a slot being set, and not INVALID).
I think users using Magisk (to root the phone) are about the only ones really attempting to install TWRP, because Magisk has means to keep TWRP around, while otherwise /e/OS updates will just restore the /e/OS recovery. Things are more complicated without a dedicated recovery partition.
But anyway, it’s not wrong. It will work either way for the moment. Unless error message.

Probably the current slot is INVALID again. Just check again like earlier, and if so, set a slot again.

What’s the filename of the /e/OS install file you are trying to install, by the way?