Surnia official built doesn’t work for me

I installed the surnia 0.7 unofficial build two years ago on my moto E. Worked fine. I discovered some months ago an official build was released for this. So I downloaded it, reformatted all and tried to install it. But I have an error :

Warning: No file_contexts
E3004: This package is for device: XT[…], surnia_uds, surnia_umts, surnia, surnia_udstd; this device is .

I tried to reinstall the unofficial build that I had lukylly kept on my pc. The reinstallation worked.

There are different versions of surnia, which XT15?? have you got? (it is displayed in Fastboot menu)

From the fastboot menu : « Product/variant: surnia XT1524 8GB P3 »

According to the message you get, script fails to retrieve the device ID (ro.product.device)

You can try to unzip the ROM image file, delete the first line from META-INF\com\google\android\updater_script, then zip it back.

If it works, please report to /e/ Gitlab.

Mine are XT1527 and work using 0.20-q-20211216151800-dev-surnia.img

Maybe try using the /e/ recovery instead of twrp, or an older version of twrp

1 Like

It worked without the assert statement. Thanks. Also TWRP asked after installer the installation if I really wanted to reboot, as there is no os installed. Which is false.

1 Like

Which you rightly ignored…

but Android is saying

there is no Android OS installed.

This is just given to discourage the faint hearted.

So it still sounds like a bug.