Switching to /e/ on zenfone3

Hi there !

I have a Zenfone 3 (Z017D). It was running lineage OS and I wanted to switch to /e/
Unfortunately something went wrong but I don’t know what.
The phone now only boots to recovery mode or fastboot mode. When I open the bootloader, I don’t have the option to boot to system. And even If I go to recovery (TWRP) and force reboot to system it reboots to fastboot. So I am stucked.

When I go to “wipe” in TWRP and look at the partition info, I can see the system partition that is filled with data (~2Go).

I tried to flash the stock android ROM from asus and it solved nothing. Once It kept boot looping.

I don’t understand what I did wrong. Any suggestions or idea would be very welcomed.

To sum up, /e/ is flashed but no OS boots. Only recovery or fastboot. No system choice in bootloader.

Thanks a lot !

Hi @diablotin welcome to the /e/ forum.

… first thoughts … what Android version did you start from … what /e/OS Android version did you try to switch to?

Hi @aibd and thanks for your replya.
My zenfone3 was running LineageOS 16 aka Android 9 and I wanted to switch to the /e/ 0.23 built on 2022 04 12.
Maybe I broke the phone when I wiped the /system partition as well as the /data and /cache ones ? I don’t remember how I did with LOS actually.
An other hint on I did wrong: on the wiki page of zenfone3 I followed the link for the recovery (I thought) and i installed the lineageos recovery, not twrp (which I had). I though I needed an recent version, mine was from 2018. But then when I tried to sideload it failed with error mounting the /cache partition. Then I reinstall a TWRP when I used the “repair” tool from the wipe menu and followed the steps.

I am sorry I was a bit messy. Previously I had no issue ! What I really don’t understand, is why I don’t have “system” in the bootloader …

Thanks again


fastboot getvar all
(bootloader) version:0.5
(bootloader) battery-soc-ok:yes
(bootloader) battery-voltage:3865000
(bootloader) variant:MTP eMMC
(bootloader) secure:yes
(bootloader) version-baseband:
(bootloader) version-bootloader:O-CS4 - 4 - user 
(bootloader) display-panel:
(bootloader) off-mode-charge:1
(bootloader) charger-screen-enabled:1
(bootloader) max-download-size:	0x1fe00000
(bootloader) partition-type:asdf:ext4
(bootloader) partition-size:asdf:	 0x4000000
(bootloader) partition-type:APD:ext4
(bootloader) partition-size:APD:	 0xd000000
(bootloader) partition-type:ADF:ext4
(bootloader) partition-size:ADF:	 0x2000000
(bootloader) partition-type:cache:ext4
(bootloader) partition-size:cache:	 0x8000000
(bootloader) partition-type:userdata:ext4
(bootloader) partition-size:userdata:	 0xd683f7000
(bootloader) partition-type:system:ext4
(bootloader) partition-size:system:	 0xf0000000
(bootloader) cpuid:046
(bootloader) project:ZE520KL
(bootloader) serialno:XXXXXXXXXXXXXXXXX
(bootloader) kernel:lk
(bootloader) product:MSM8953
Finished. Total time: 0.281s

Having prepared this reply I now see your later edit! … There are reports that users can sometimes switch from a LineageOS build of the same Android version but …

If you simply mean as in your first post

No system choice in bootloader.

Maybe just, "there is no bootable image on /system ".

Edit in a quick search I cannot verify your system partition information, but are you reassured that /system exists, but is corrupted in some way?

/e/ install pages used to include a prerequisite section in red which read

Caution: Do not install /e/OS on top of a higher version of stock OS.
Before installing /e/OS ensure your device has the latest stock OS of the same version as /e/OS.
If only lower versions of the stock are available then install the last available lower version before installing /e/OS.

Maybe it was thought that this paragraph is a bit clumsy and not device specific, but please bear it in mind if you follow this suggestion.

I think the best thing to do right now is to search how to get the latest Asus ROM for the device; you might try

As you have working Fastboot mode there should be no problem flashing the device with a Factory ROM.

There is another thing to be aware of. Quoting from this week’s Week 44, 2022 : Development and Testing Updates

End of official support for Nougat, Oreo and Pie :disappointed: For Pie, Oreo and Nougat the official /e/OS support draws to a close.

Reasons for dropping official support are:

  • newly released applications like App Lounge, Advanced privacy code has not been customized for these OS versions.
  • lack of dedicated ROM Maintainers
  • no support upstream (Lineage dropped support for Pie sometime back)
  • device trees will continue to exist in the Gitlab and users with build skills can create custom ROMs on these builds
  • Security patches and vendor patches for the Pie, Oreo and Nougat code will be updated based on availability.

:nerd_face: Google stops security patches for OS after some time. Similarly, Vendors drop support for older models when they release newer models in the market. Then it depends on developers from various communities to backport the patch

We probably did not have reports that the last /e/ ROMs from April 2022 were faulty or they would have been withdrawn … but the label “Beta” is a clue that this is going to be a bit experimental, I think.

in a quick search I cannot verify your system partition information, but are you reassured that /system exists, but is corrupted in some way?

I can see the /system partition but as I wiped it nothing was left on it. So that may be the issue.

My LineageOS was version 9 (lOS 16) and /e/ is also 9 for my phone. I notice the beta status but I wanted to give it a try. LOS is already very nice but I wanted microG and no google DNS/ntp etc… that was the reason.

Yesterday I tryied the last firmwre from asus for the zenfone3 but it did not solve the problem. I’m gonna try again even with older version.

In any way, zenfone3 is no more maintained by anyone, so I have to live with my outdated OS/security breach and so on … I cannot make a choice for a new phone, all have pros and cons but I would go for FP4 which has very good support

Thanks, I’ll post any update soon on my findings :slight_smile:

BTW, when I go to file manager in TWRP, and open the /system folder there is nothing. But the system partition does not seem to be mounted so I guess this is why, right ?

The Asus ROM did boot though? I would not recommend going back to older versions.

I expect that is correct.

… and you already tried just to run the install instructions, based on what you learned?

wiping /system is good in TWRP although some would say not strictly necessary … I suppose if you can connect with adb you could do df -h / or df -a to learn if system never even got populated by the install instructions.

Ok so here is where I am.

I downloaded the oldest Asus firmware, it did boot and got the “welcome screen”
Then I decided to upgrade to lastest firmware and then install lineageos and then /e/. I got back to the fastboot issue.
Now I stopped at the lineageos with microG from 2022 04 10 and it does boot. So probably there is some incompatibility ?

Maybe the safest is to stay with LOS16 microG …

My observation from a troubleshooting POV would be that you repeated the “deviation from ideal” in that /e/ might well be quite sensitive to installing straight over the latest factory ROM.

Yes you are right. But when do I deviate ? I cannot find any procedure from what to what I should go …

You are right that you are on the face of it following the install instructions. I guess I should have said it was a deviation from my recommendation, which would have included the prerequisite I quoted earlier.

So I feel a better path would be to try to use the latest Factory ROM, boot it, then start the /e/ install from that point.

I should have better written /e/ might be sensitive to require installing straight over a factory ROM.

Ok, I understand. I though starting from LOS would help since /e/ is based on LOS but maybe I was wrong.
I managed to get LOS to work. For the moment I am gonna rest and will try /e/ later but the beta status is not reassuring ^^

Thanks for your help !

1 Like