Sync tasks from Nextcloud server to tasks app

Hi,
So I host my own private Nextcloud server, and I managed to sync my calendar and contacts with it.
I just started using the tasks feature of Nextcloud, and I was hoping that the tasks would automatically be synced, but they’re not.
I’m using davx5 to sync the calendar & contacts, but the tasks don’t work.
I ticked the ‘tasks’ checkbox in the davx5 app as well…

Does anyone know how to sync Nextcloud tasks to my tasks app?

AFAIK “tasks” in /e/ is only local.

My workaround is to install “tasks” from F-Droid. But do not expect a full functionality. For example recurrent tasks do not work

I’ve added my personal nextcloud account to /e/ and task sync worked out of the box with the “native” tasks app (which is just on old version of OpenTasks iirc).

Did you try to initiate a resync by swiping down in the task apo?

No. Normally it will sync with your /e/ account when you add the account, and the tasks from your account will appear in the Tasks app. If that isn’t happening for you, it’s a bug, and it would help if you could raise a bug report in gitlab

1 Like

Hi,

It’s working here, I’m adding a step-by-step so you could check that we share the same eyes :wink:

In Tasks app, you should see the “Personal” list with your account name:
image

Rem : you can hide the local list from the 3-dot menu, then “Displayed lists”:
image

image

On cloud, you should also see the “Personal” list, and make it default in Settings at bottom:

Then try to add a task on phone:
image

Then wait some time (half an hour ?), it should appear on cloud:
image

Note : you can speed-up the sync process in Settings/Accounts, switching the Tasks sync off & on (it should shortly display “Syncing now” when enabling):


Under the hood, we can see that Tasks rely on Calendar: tasks/src/store at master · nextcloud/tasks · GitHub.
So (I didn’t check that), I think it may help to have a calendar with the same name (“Personal”) as tasks list :wink:
image

1 Like

I quickly checked in “calendarobjects” table within my NC MariaDB database, I could find the task entry:

I can’t swipe down in the app? I can press ‘refresh’ though.

But I have my own personal Nextcloud server, and added it to the davx5 app, and it doesn’t sync.
Btw, I don’t have an /e/ cloud server / account. I’m just using the original Nextcloud server.

Thank @smu44 ou for the explanation, it is very useful. It works on my side: the “Personal” task category is syncing correctly between my phone and ecloud. However, when I create other task categories (I use tasks a lot!), I can’t manage to have them appearing on my phone. I tried adding synced calendars on DAVx5, among other intents, but nothing work. Have you managed something like this on your side?
Best,
Florent

Just to be sure : you mean categories, like the “test 1” at the bottom?
image

Unfortunately, after some testings I came to the conclusion that Tasks Android app don’t manage them. At all :frowning:

However, if your concern is about lists, I could create a new list on /e/ Cloud, and sync it with my phone, no problem. Had to use the “Refresh calendar list” in DavX5:
image

image

Sorry, my question was sloppy. I meant lists. On https://ecloud.global/apps/tasks, I click on “ajouter une liste” (“add a list”), and for instance I create a list named “Work”. I can’t find how to get this new list synced on my cellphone.

You have to refresh calendars in DavX5, I edited my previous post :wink:

Sorry, I forgot : you also have to use the “Refresh” from the 3-dot menu in Tasks app.

Just to clarify : in DavX5 the double-circle arrows at bottom of calendar section refreshes the content only.
To refresh calendars list, or tasks lists, you have to use the 3-dot menu at top.

Hi @smu44 , thanks a lot for the feedback. You are right of course, but I was mislead by the fact that I manually installed DAVx5 and manually set a synchronisation with my e.email account from there, which was not picked by the native Task app. When I refreshed the app list there, nothing new appeared in my task app.
In fact, DAVx5 was already natively installed on the OS and it is accessible through : Parameters> Accounts > xxxxx@e.email > My Account > Settings.
There I can go to agendas and refresh the agenda list.
Thanks a lot for your help, merci pour le coup de main !

1 Like

you’re very welcome :slight_smile:

So I have fixed the problem.
I had to login in /e/ with my Nextcloud account.
Go to Settings → Accounts → Add Account → /e/ (on the top of the list).
Click below the login button on ‘Add a specific server’ (or something like that), and type your Nextcloud server URL there.
Then, in E-Mail, type your Nextcloud email address, NOT your username.
In Password, don’t type your Nextcloud password, instead generate an app-password for /e/ and enter that password.
Then it should open the account manager, show your Nextcloud account, and the default tasks app should be able to sync your Nextcloud tasks.

2 Likes