Temporarily Booting a custom recovery using fastboot -- help please

Asus Zenfone 8 A12
I brought it back to A11 without any problems
I flashed the vendor boot partition
2022-07-01 00:27 96M

I get stuck after flashing the custom recovery (https://images.ecloud.global/dev/sake/recovery-e-1.0-r-20220527188878-dev-sake.img)
Phone loops in ‘START,Restart bootloader, Recovery mode,Power off’
Choose Recovery mode and phone cames back to ‘START,Restart bootloader, Recovery mode,Power off’.

I tried it also with twrp and I have the same problem !
The flashing of the temporarily booting image is fine but the phone won’t reboot
fastboot boot /Users/eboelens/Downloads/twrp.img
Sending ‘boot.img’ (98304 KB) OKAY [ 2.114s]
Booting OKAY [ 10.381s]

fastboot flash boot /Users/eboelens/Downloads/recovery-e-1.0-r-20220527188878-dev-sake.img
Sending ‘boot_a’ (98304 KB) OKAY [ 2.118s]
Writing ‘boot_a’ OKAY [ 0.180s]
Finished. Total time: 2.380s

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I flashed back to stock A11 , I’m running now without /e/ :frowning_face:
Any idea please ?

i tried again and noticed that after flashing vendor boot I can’t start the phone , but keep getting into fastboot

I seem to allow myself to become confused by the links you have provided. So I am not quite certain where in the process you are.

So just to clarify

Is the failure at this point?

  1. Manually reboot into recovery mode

We see this tip:

Tip: Outdated fastboot releases dropped legacy A/B support, so it might attempt to flash to boot__a / boot__b rather than boot_a / boot_b if you try to flash boot. In this case, you must update fastboot to a release newer than or equal to 31.0.2. Alternatively, you can manually specify which slot to flash to based on what slot fastboot failed to flash to. For example, if fastboot fails to flash to boot__a, you must flash to boot_a.

Are you fully certain of all the points raised here?

Are there any specific questions you have about these points?

thank you so much for helping
Yes to all except the tip maybe.

I dont really understand
You can see the flash is on OKAY on boot_a
I’m under the impression that it’s ok
correct ?
or not ?
If thats the reason i will look for the right version

at the moment I’m on OSX and using Homebrew:
adb help
Android Debug Bridge version 1.0.41
Version 29.0.4-5871666,

maybe it is better using the platform tools manually ?
is that the right direction that I have to go?

The latest version is always a good idea, particularly necessary on new devices and hardware.

It is unusual to see this explicit tip. So I would treat the tip as required, especially as you are experiencing difficulties at the mentioned stage!

1 Like

I wanted to post this but you were ahead of me

Very strange
I downloaded the latest platform tools Notas de la versión de las Herramientas de la plataforma del SDK  |  Desarrolladores de Android  |  Android Developers for Mac
After installing them I get:

~ % fastboot --version
fastboot version 29.0.4-5871666
Installed as /usr/local/bin/fastboot

I don’t understand…

I tried on a Windows 10 machine (virtualbox) and I get the right version
I tried also on a linux machine and I get also the right version

So I can conclude that the official platform tools for OSX do not give the right information.

Using the Android Developers tools, you are not really installing platform tools; you are just providing them.

You are being confused; when you called fastboot, you still called “system” fastboot, or put another way, fastboot as originally installed by the system.

Having two sets of platform tools is not ideal!

First, please see what progress you make with this: Installing adb and fastboot on a Linux PC.

As you have a Mac you will want to follow the guide you already linked, but perhaps the /e/ link will throw a different light on it.

Neither guide really helps you understand “what if I already have an old set of platform-tools?”

Are you able to uninstall your existing platform-tools? This will definitely make things easier.

ok see my post above ‘edited’
I’m now on Fedora (Virtualbox) and
Schermafbeelding 2022-07-03 om 21.43.57

very confusing
is the version okey or not ?
newer than or equal to 31.0.2

This still looks to old! We were asked for

newer than or equal to 31.0.2

Newer versions always get a larger version number. Sorry, :blush:

A demo

I have no system platform tools.
Let’s use the command which to look for properly installed adb

iain@laptop:~$ which adb

Tells us – absent.

My Platform Tools are extracted to ~/platform-tools

iain@laptop:~$ cd platform-tools/
iain@laptop:~/platform-tools$ ./adb --version
Android Debug Bridge version 1.0.41
Version 33.0.1-8253317
Installed as /home/iain/platform-tools/adb
iain@laptop:~/platform-tools$ ./adb devices
List of devices attached
53xxxx54	device

The really significant thing here is the use of


… this says “use the command you find in this folder”.

In windows I get a good version
Schermafbeelding 2022-07-03 om 22.03.32

sorry for all your time
i deleted everything from android platform tools from my mac (there was a lot of junk on it)
Reinstalled with homebrew and I’m now on

eboelens@iMacHoofd ~ % adb --version
Android Debug Bridge version 1.0.41
Version 33.0.2-8557947
Installed as /usr/local/bin/adb

tomorrow I will try to install the recovery again…
I will post back

Good work!

Extended comment.

I could have tried to guide you to use latest Platform Tools, while you had older Platform Tools installed within your system.

I feel it is much better that you took this time consuming route. There is more stuff in Platform Tools than just adb and fastboot; we do not need to become confused if any other side issues should emerge, especially as we are aware of the issue described in your instructions as “dropped legacy A/B support”.

I tried again flashing vendor_boot and recovery but I have still the same problem. I cannot boot into recovery !

eboelens@iMacHoofd ~ % adb --version
Android Debug Bridge version 1.0.41
Version 33.0.2-8557947
Installed as /usr/local/bin/adb
eboelens@iMacHoofd ~ % fastboot devices
M4AIB761X5794** fastboot
eboelens@iMacHoofd ~ % fastboot flash vendor_boot /Users/eboelens/Downloads/vendor_boot.img
Sending ‘vendor_boot’ (98304 KB) OKAY [ 2.309s]
Writing ‘vendor_boot’ OKAY [ 0.192s]
Finished. Total time: 2.513s
eboelens@iMacHoofd ~ % fastboot devices
M4AIB761X5794** fastboot
eboelens@iMacHoofd ~ % fastboot flash boot /Users/eboelens/Downloads/recovery-e-1.0-r-20220527188878-dev-sake.img
Sending ‘boot_a’ (98304 KB) OKAY [ 2.381s]
Writing ‘boot_a’ OKAY [ 0.178s]
Finished. Total time: 2.578s
eboelens@iMacHoofd ~ %

After flashing vendor_boot it is not possible start the system but direct ‘download mode’
is this normal ?

I do not know the device, I can imagine that would certainly be the case


I have learned never to allow an Android device to boot to system – or do anything under the control of Android – while I am trying to flash it.

We know devices vary in their behaviour … but if I were following these instructions I would be very careful to do the two flash jobs … try to force stop the device … and immediately on halt get the Recovery started by button control.

The reason I say this is that while the manufactures system controls the device, it will try its hardest to deflect intrusion.

I tried again flashing twrp with succes this time , reboot again in twrp, and reboot again with the recovery keys ,
factory reset, flashing /e/, reboot , e screen bootloop :confused: , reboot into recovery, recovery from /e/ appears :smiley: , factoryreset, flashing /e/ , reboot and boom I’m in /e/ :grinning:

can you explain what actually happened?

Sometimes a Factory reset after a “bootloop on First boot” does result in success.

Speculating, somewhat, one explanation for this is that First boot is always hard for a device; sometimes it can take quite a long time. maybe sometimes the device actually cannot manage the task of First boot, and leaves the device unstable.

As it is a First boot, an attempt to “do it like the last successful boot” will also fail – hence the loop.

A Factory reset, allows the device to have another go, fresh!

1 Like