Zenfone 8 keeps rebooting in bootloader after flashing recovery

I’m following the guide to install /e/ on the Asus Zenfone 8:
I updated the stock OS to latest android11 (next update was to android 12).
I downloaded the unlock app and unlocked the device. Rebooted, go through the android setup wizards again, enable usb debugging.
I booted in the bootloader and installed the vendor_boot (Index of /pub/lineageos/full/sake/20220715) and the recovery( recovery-e-1.1-r-20220629200015-dev-sake.img ).
Lastly, I selected the recovery mode option.

The device keeps rebooting to the bootloader. There’s no recovery booting, there’s no android booting either.
Shutting the device down is impossible, the only thing it does is rebooting.

$ sudo fastboot flash vendor_boot vendor_boot.img 
Sending 'vendor_boot' (98304 KB)                   OKAY [  2.309s]
Writing 'vendor_boot'                              OKAY [  0.199s]
Finished. Total time: 2.518s
$ sudo fastboot flash boot recovery-e-1.1-r-20220629200015-dev-sake.img 
Sending 'boot_b' (98304 KB)                        OKAY [  2.312s]
Writing 'boot_b'                                   OKAY [  0.209s]
Finished. Total time: 2.535s

I suspect the following may be of interest:

(bootloader) parallel-download-flash:no
(bootloader) hw-revision:20001
(bootloader) unlocked:yes
(bootloader) off-mode-charge:1
(bootloader) charger-screen-enabled:1
(bootloader) battery-soc-ok:yes
(bootloader) battery-voltage:4282
(bootloader) version-baseband:
(bootloader) version-bootloader:Post-CS3-1-WW-user
(bootloader) erase-block-size: 0x1000
(bootloader) logical-block-size: 0x1000
(bootloader) variant:SM_ UFS
(bootloader) partition-type:asuskey6:raw
(bootloader) partition-size:asuskey6: 0x1AD5000
(bootloader) partition-type:asuskey5:raw
(bootloader) partition-size:asuskey5: 0x100000
(bootloader) partition-type:asuskey4:raw
(bootloader) partition-size:asuskey4: 0x100000
(bootloader) partition-type:asuskey3:raw
(bootloader) partition-size:asuskey3: 0x100000
(bootloader) partition-type:asuskey2:raw
(bootloader) partition-size:asuskey2: 0x100000
(bootloader) partition-type:asuskey:raw
(bootloader) partition-size:asuskey: 0x100000
(bootloader) partition-type:sysconf:raw
(bootloader) partition-size:sysconf: 0x20000
(bootloader) partition-type:fsc:raw
(bootloader) partition-size:fsc: 0xBDB000
(bootloader) partition-type:fsgCA:raw
(bootloader) partition-size:fsgCA: 0x500000
(bootloader) partition-type:fsg:raw
(bootloader) partition-size:fsg: 0x500000
(bootloader) partition-type:modemst2:raw
(bootloader) partition-size:modemst2: 0x500000
(bootloader) partition-type:modemst1:raw
(bootloader) partition-size:modemst1: 0x500000
(bootloader) partition-type:ALIGN_TO_128K_2:raw
(bootloader) partition-size:ALIGN_TO_128K_2: 0x1A000
(bootloader) partition-type:rtice:raw
(bootloader) partition-size:rtice: 0x1BAA1000
(bootloader) partition-type:spunvm:raw
(bootloader) partition-size:spunvm: 0x2000000
(bootloader) partition-type:tzsc:raw
(bootloader) partition-size:tzsc: 0x20000
(bootloader) partition-type:connsec:raw
(bootloader) partition-size:connsec: 0x20000
(bootloader) partition-type:mdcompress:raw
(bootloader) partition-size:mdcompress: 0x1400000
(bootloader) partition-type:vm-data:raw
(bootloader) partition-size:vm-data: 0x20A4000
(bootloader) partition-type:secdata:raw
(bootloader) partition-size:secdata: 0x7000
(bootloader) partition-type:uefivarstore:raw
(bootloader) partition-size:uefivarstore: 0x80000
(bootloader) partition-type:storsec:raw
(bootloader) partition-size:storsec: 0x20000
(bootloader) partition-type:logdump:raw
(bootloader) partition-size:logdump: 0x4000000
(bootloader) partition-type:logfs:raw
(bootloader) partition-size:logfs: 0x800000
(bootloader) partition-type:limits-cdsp:raw
(bootloader) partition-size:limits-cdsp: 0x1000
(bootloader) partition-type:limits:raw
(bootloader) partition-size:limits: 0x1000
(bootloader) partition-type:splash:raw
(bootloader) partition-size:splash: 0x20A4000
(bootloader) partition-type:apdp:raw
(bootloader) partition-size:apdp: 0x40000
(bootloader) partition-type:dip:raw
(bootloader) partition-size:dip: 0x100000
(bootloader) partition-type:devinfo:raw
(bootloader) partition-size:devinfo: 0x1000
(bootloader) partition-type:qweslicstore_b:raw
(bootloader) partition-size:qweslicstore_b: 0x40000
(bootloader) partition-type:vendor_boot_b:ext4
(bootloader) partition-size:vendor_boot_b: 0x6000000
(bootloader) partition-type:featenabler_b:raw
(bootloader) partition-size:featenabler_b: 0x20000
(bootloader) partition-type:cpucp_b:raw
(bootloader) partition-size:cpucp_b: 0x100000
(bootloader) partition-type:multiimgoem_b:raw
(bootloader) partition-size:multiimgoem_b: 0x8000
(bootloader) partition-type:vm-bootsys_b:raw
(bootloader) partition-size:vm-bootsys_b: 0x10625000
(bootloader) partition-type:shrm_b:raw
(bootloader) partition-size:shrm_b: 0x20000
(bootloader) partition-type:imagefv_b:raw
(bootloader) partition-size:imagefv_b: 0x200000
(bootloader) partition-type:uefisecapp_b:raw
(bootloader) partition-size:uefisecapp_b: 0x200000
(bootloader) partition-type:dtbo_b:raw
(bootloader) partition-size:dtbo_b: 0x1800000
(bootloader) partition-type:vbmeta_b:raw
(bootloader) partition-size:vbmeta_b: 0x10000
(bootloader) partition-type:qupfw_b:raw
(bootloader) partition-size:qupfw_b: 0x14000
(bootloader) partition-type:devcfg_b:raw
(bootloader) partition-size:devcfg_b: 0x20000
(bootloader) partition-type:boot_b:raw
(bootloader) partition-size:boot_b: 0x6000000
(bootloader) partition-type:keymaster_b:raw
(bootloader) partition-size:keymaster_b: 0x80000
(bootloader) partition-type:dsp_b:raw
(bootloader) partition-size:dsp_b: 0x4000000
(bootloader) partition-type:abl_b:raw
(bootloader) partition-size:abl_b: 0x100000
(bootloader) partition-type:mdtp_b:raw
(bootloader) partition-size:mdtp_b: 0x2000000
(bootloader) partition-type:mdtpsecapp_b:raw
(bootloader) partition-size:mdtpsecapp_b: 0x400000
(bootloader) partition-type:bluetooth_b:raw
(bootloader) partition-size:bluetooth_b: 0x200000
(bootloader) partition-type:modem_b:raw
(bootloader) partition-size:modem_b: 0xDC00000
(bootloader) partition-type:hyp_b:raw
(bootloader) partition-size:hyp_b: 0x800000
(bootloader) partition-type:tz_b:raw
(bootloader) partition-size:tz_b: 0x400000
(bootloader) partition-type:aop_b:raw
(bootloader) partition-size:aop_b: 0x80000
(bootloader) partition-type:qweslicstore_a:raw
(bootloader) partition-size:qweslicstore_a: 0x40000
(bootloader) partition-type:qmcs:raw
(bootloader) partition-size:qmcs: 0x1E00000
(bootloader) partition-type:vendor_boot_a:ext4
(bootloader) partition-size:vendor_boot_a: 0x6000000
(bootloader) partition-type:featenabler_a:raw
(bootloader) partition-size:featenabler_a: 0x20000
(bootloader) partition-type:cpucp_a:raw
(bootloader) partition-size:cpucp_a: 0x100000
(bootloader) partition-type:multiimgoem_a:raw
(bootloader) partition-size:multiimgoem_a: 0x8000
(bootloader) partition-type:vm-bootsys_a:raw
(bootloader) partition-size:vm-bootsys_a: 0x10625000
(bootloader) partition-type:shrm_a:raw
(bootloader) partition-size:shrm_a: 0x20000
(bootloader) partition-type:imagefv_a:raw
(bootloader) partition-size:imagefv_a: 0x200000
(bootloader) partition-type:uefisecapp_a:raw
(bootloader) partition-size:uefisecapp_a: 0x200000
(bootloader) partition-type:dtbo_a:raw
(bootloader) partition-size:dtbo_a: 0x1800000
(bootloader) partition-type:vbmeta_a:raw
(bootloader) partition-size:vbmeta_a: 0x10000
(bootloader) partition-type:qupfw_a:raw
(bootloader) partition-size:qupfw_a: 0x14000
(bootloader) partition-type:devcfg_a:raw
(bootloader) partition-size:devcfg_a: 0x20000
(bootloader) partition-type:boot_a:raw
(bootloader) partition-size:boot_a: 0x6000000
(bootloader) partition-type:keymaster_a:raw
(bootloader) partition-size:keymaster_a: 0x80000
(bootloader) partition-type:dsp_a:raw
(bootloader) partition-size:dsp_a: 0x4000000
(bootloader) partition-type:abl_a:raw
(bootloader) partition-size:abl_a: 0x100000
(bootloader) partition-type:mdtp_a:raw
(bootloader) partition-size:mdtp_a: 0x2000000
(bootloader) partition-type:mdtpsecapp_a:raw
(bootloader) partition-size:mdtpsecapp_a: 0x400000
(bootloader) partition-type:bluetooth_a:raw
(bootloader) partition-size:bluetooth_a: 0x200000
(bootloader) partition-type:modem_a:raw
(bootloader) partition-size:modem_a: 0xDC00000
(bootloader) partition-type:hyp_a:raw
(bootloader) partition-size:hyp_a: 0x800000
(bootloader) partition-type:tz_a:raw
(bootloader) partition-size:tz_a: 0x400000
(bootloader) partition-type:aop_a:raw
(bootloader) partition-size:aop_a: 0x80000
(bootloader) partition-type:ddr:raw
(bootloader) partition-size:ddr: 0x7BB000
(bootloader) partition-type:cdt:raw
(bootloader) partition-size:cdt: 0x20000
(bootloader) partition-type:ALIGN_TO_128K_1:raw
(bootloader) partition-size:ALIGN_TO_128K_1: 0x1A000
(bootloader) partition-type:xbl_config_b:raw
(bootloader) partition-size:xbl_config_b: 0x1F5000
(bootloader) partition-type:xbl_b:raw
(bootloader) partition-size:xbl_b: 0x600000
(bootloader) partition-type:xbl_config_a:raw
(bootloader) partition-size:xbl_config_a: 0x1F5000
(bootloader) partition-type:xbl_a:raw
(bootloader) partition-size:xbl_a: 0x600000
(bootloader) partition-type:userdata:f2fs
(bootloader) partition-size:userdata: 0x38C19D3000
(bootloader) partition-type:metadata:ext4
(bootloader) partition-size:metadata: 0x1000000
(bootloader) partition-type:vbmeta_system_b:raw
(bootloader) partition-size:vbmeta_system_b: 0x10000
(bootloader) partition-type:vbmeta_system_a:raw
(bootloader) partition-size:vbmeta_system_a: 0x10000
(bootloader) partition-type:super:raw
(bootloader) partition-size:super: 0x1C0000000
(bootloader) partition-type:xrom_b:ext4
(bootloader) partition-size:xrom_b: 0x20000000
(bootloader) partition-type:xrom_a:ext4
(bootloader) partition-size:xrom_a: 0x20000000
(bootloader) partition-type:asusfw_b:raw
(bootloader) partition-size:asusfw_b: 0x4000000
(bootloader) partition-type:asusfw_a:raw
(bootloader) partition-size:asusfw_a: 0x4000000
(bootloader) partition-type:ftm:raw
(bootloader) partition-size:ftm: 0x8000000
(bootloader) partition-type:APD:ext4
(bootloader) partition-size:APD: 0xC800000
(bootloader) partition-type:ADF:ext4
(bootloader) partition-size:ADF: 0x2000000
(bootloader) partition-type:sysinfo:raw
(bootloader) partition-size:sysinfo: 0x100000
(bootloader) partition-type:gpt:raw
(bootloader) partition-size:gpt: 0x100000
(bootloader) partition-type:asdf:ext4
(bootloader) partition-size:asdf: 0x18000000
(bootloader) partition-type:batinfo:ext4
(bootloader) partition-size:batinfo: 0x2000000
(bootloader) partition-type:factory:raw
(bootloader) partition-size:factory: 0x2000000
(bootloader) partition-type:fde:raw
(bootloader) partition-size:fde: 0xA00000
(bootloader) partition-type:frp:raw
(bootloader) partition-size:frp: 0x80000
(bootloader) partition-type:keystore:raw
(bootloader) partition-size:keystore: 0x80000
(bootloader) partition-type:misc:raw
(bootloader) partition-size:misc: 0x100000
(bootloader) partition-type:persist:raw
(bootloader) partition-size:persist: 0x2000000
(bootloader) partition-type:ssd:raw
(bootloader) partition-size:ssd: 0x2000
(bootloader) has-slot:modem:yes
(bootloader) has-slot:system:no
(bootloader) current-slot:b
(bootloader) has-slot:boot:yes
(bootloader) slot-retry-count:b:1
(bootloader) slot-unbootable:b:no
(bootloader) slot-successful:b:no
(bootloader) slot-retry-count:a:2
(bootloader) slot-unbootable:a:yes
(bootloader) slot-successful:a:yes
(bootloader) slot-count:2
(bootloader) secure:yes
(bootloader) serialno:REDACTED
(bootloader) product:lahaina
(bootloader) mask_unlocked:N
(bootloader) rt_unlocked:locked
(bootloader) rd_unlocked:locked
(bootloader) cid:ASUS
(bootloader) cpuid:135
(bootloader) max-download-size:536870912
(bootloader) project:ZS590KS
(bootloader) snapshot-update-status:none
(bootloader) is-userspace:no
(bootloader) max-download-size:805306368
(bootloader) kernel:uefi

I’m not sure where to go from here. I’ve considered installing TWRP instead, but it does not appear to have an image suited for this device.

I’ve extracted the boot.img and vendor_boot.img files from https://dlcdnets.asus.com/pub/ASUS/ZenFone/ZS590KS/UL-I006D-ASUS- The firmware of the latest android 11 from Asus. I used the payload_dumper.py script on payload.bin which resulted in all the partitions being exported to .img format.

I flashed those back to the phone’s boot and vendor_boot partitions and the phone boots without problem.

The boot loop is probably caused by the fact I can’t get into recovery (just boots back into bootloader), so I can’t install the OS.

I’ve tried the recovery images for both /e/1.1 and 1.0.

I should up my searching skills. Temporarily Booting a custom recovery using fastboot -- help please - #15 by eboelens
This guy has the same problem. I’ll see if I can try his way… Tomorrow :slight_smile:

Unfortunately no joy yet.
In the post above it mentions the platform tools might be outdated. Just like in the other post, I have to report having the latest platform tools, and nothing other:

$ adb --version
Android Debug Bridge version 1.0.41
Version 33.0.2-8557947

I have attempted the same steps on another device (mac), the same issue appears: recovery does not want to start.

I’ve put back the original ASUS images and then I can load the recovery mode. I’ve wiped all data/factory reset and tried to flash the vendor_boot and recovery image again.
Unfortunately, no success. The recovery mode is inaccessible again.

Could this be an issue with a new make of the device?

I do notice, despite using the latest platform-tools, it’s still writing to boot_b:

$ sudo fastboot flash boot ~/Downloads/asus/recovery-e-1.1-r-20220629200015-dev-sake.img 
Sending 'boot_b' (98304 KB)                        OKAY [  2.309s]
Writing 'boot_b'                                   OKAY [  0.198s]
Finished. Total time: 2.522s

I’ve omitted the vendor_boot step and I’m able to load the recovery menu.

I’ve rebooted the device and the installation of /e/ started. It seems to be stuck for about 15 minutes now at:

Waiting for flashing full randump...
D - 0 - boot_ddi_entry
B- 122183 - usb: platform

Next steps I will attempt is to:

  • Reboot to recovery
  • factory reset
  • sideload /e/ again
  • reboot to bootloader
  • load vendor_boot
  • reboot

Seems like the device is stuck now. Rebooting keeps bringing me back to the same state. Bootloader does not activate.
At this point I think I bricked my device. Any help towards a recovery would be appreciated

It this situation it can be reassuring if the phone will power down and if charging will commence and give an accurate idea of increasing charge level.

Sorry not to be able to help more but doing nothing till fully charged might be wise, or, having seen the above, you might think of allowing to phone to discharge, on the basis that we used to pull the battery in this sort of event, back in the day.

Hello aidb and thank you for your reply.
I am able to shut down the device when it’s not connected to USB.
I’ve connected the phone to the Asus charger. No charging graphic comes up, but it does go back to the installation steps.
The messages past “Waiting for flashing full ramdump…” are now slightly different (I noticed the behaviour when not connected to a computer):

B - 531401 - do_ddr_training, Start
D - 0 - do_ddr_training, Delta
D - 31 - sbl1_do_ddr_training
D - 0 - boot_ddi_entry
B - 122457 - usb: platform

The device was fully charged when I started.

I guess the next step is waiting until the device is discharged.

I am sure you are searching those errors. I won’t jump to speculative conclusions, but as the device is still talking to you and trying to help you I am fairly confident it is not bricked. I have got some hits on those errors but I do not know the device well enough to suggest an exact way forward. I would be trying to collect full info on the board used in that device, and the way it talks to adb.

(Good to know that you were already fully aware to have a fully charged device! :slight_smile: )

Good luck.

I’m sorry for the bold large type. It was unintentional, and I’ve edited it in the post. By no means I was “shouting”. I do appreciate your input a lot.

Thank you for impressing on me that the device is probably not bricked. I understand the risks of bricking a device. It would be the first one though.

Honestly I’m not sure what you mean by errors. The output does not present any errors the way I understand it, just logging output? I’m also not sure what or where to look for. I’m not that well versed in the Android flashing business, but I’m learning :slight_smile:
As far as I can tell, the device is not visible to fastboot or adb in the current state.
I suspect draining the battery might take a small week.

Thanks for the suggestion to look for the errors. It appears a lot of Asus Zenfone 8 users are stuck at this step. I’ll do some reading.

Quite, sorry, completely the wrong word used!

It is indeed, I agree, output :sunny:

The Asus forums don’t look overly enhousiastic about the message. I read a lot about sending it in for repair and having the motherboard replaced.
Looks like I’ll be starting an RMA case soon.

One interpretation of this is that fastboot is still in progress of a task it was given. Does it fit with what you see that you are still (loosely) in fastboot but “busy”?

I was making the link with your output to the Qualcomm SM8350 (I think you have Snapdragon 888 5G, you should verify any of these clues).

You might look further into the recovery possibilities of EDL with this family of devices. Please be aware that this is a fairly high level of intervention.

A picture says a thousand words :slight_smile:

The phone has already drained it’s battery. It went a lot faster than I anticipated.

This seems to be a common issue with older zenfone 8 devices if I can believe the topics I referenced in my last post. The Asus solution for this issue is to replace the motherboard.

I was thinking to buy an Asus Zenfone 8, because i want a better phone then the Gigaset GS290.
Th camera is not so good, i have problem with an echo and blackscreens when i am calling etc.

But after seeing this post, i think that this idea is not so good.
I don’t like it to buy and brick a phone.

Hi Michiel,

I’m sorry my post convinced you not to go with the Asus Zenfone 8.
The technical issues I’ve experienced are unfortunate and the issue appears to be on the side of Asus, not /e/. Unfortunately, the device I received was an old device. I did receive a warning from customer support that the factory warranty of the device expired and had to provide the invoice to prove I recently bought it.
I’m still looking forward to receiving back the phone from the repair service and to put /e/ on it.
In past experiences, Asus makes very decent hardware, the build quality of the device is superior to any device of the same pricing range I’ve encountered. The hardware specs also surpass any device in the same category.
I’m currently on an Asus zenfone 6 (/e/ beta) and a samsung s9+ (bought with /e/ pre-installed from here. The samsung currently is my main device and I want to get rid of it as soon as possible.
The build quality is not good, the curved screen is, let’s put it politely, not convenient to work with and the hardware is full of bugs. I could write a book on the grieves I have with that device. The moment I get the Asus Zenfone 8 working, I think I’ll axe the samsung to get some kind of satisfaction.

The past events of the Asus Zenfone 8 were unfortunate, but it will not stop me to get it working. I’m convinced of the device and it’s capabilities.

1 Like

Maybe you can try twrp as recovery also? /e/ recovery won’t work first after that I tried twrp. After that it was /e/ recovery that started.

Hello @eboelens Thank you for your suggestion.
The phone came back from Asus 3 days ago and I was planning to spend my afternoon installing /e/ again.
Have you had any luck with installing Twrp? Which steps did you take to install?

I’d like to provide an update here.

I’ve followed the instructions again as on the installation page was provided.
The result was the same. Same errors, same ramdump.
I did manage to boot /e/ 1.2 twice. It was not a pleasant sight. screen input took almost 60 seconds to be recognized, for each input. The first boot wizard crashed several times.

I remain with my belief that the vendor_boot linked on the installation page will not work and is not intended for Android 11.

LineageOS, where the vendor boot comes from, currently only supports Android 12.

I did reach out to the LineageOS community and asked for help or archives of older versions of vendor_boot, but unfortunately there are none.

Useful tips I figured out along the way:
Android 12 beta page provides a downgrade to Android 11, but no upgrade path from there: Android 12 Developer Preview Program | ASUS Global
Android 13 beta page provides a downgrade to Android 12, which in turn can be upgraded to the latest version or downgraded to the latest Android 11: Android-13-Beta | ASUS Global

When the ramdump error appears, let the battery drain until it’s certainly turned off, then charge it to capacity and booting into fastboot should be fine.

I’m now reluctantly running LineageOS, because I do need a phone. I’ll be following this project closely. The past 3 years I’ve been on /e/ I’ve always been very happy with it and I’m looking forward having it again, albeit under better, less stressful circumstances.

I’d like to thank all repliers in this thread for their help and insight. I’m also very grateful towards everybody who is making /e/ a thing!

As this is a serious charge which would preclude the use of /e/ on this device, I did a little checking. This is not my recommendation for others to follow, but just a first pass look.

In this thread https://forum.xda-developers.com/t/kernel-05-08-2022-android-12-kirisakura-2-0-8_s-for-asus-zenfone-8-aka-sake.4295287/ it is suggested that

Extract boot.img, vendor_boot.img as well as dtbo.img from matching firmware you are on and flash them via fastboot.

While LineageOS included "Add support for vendor_boot image header version 4" here. https://review.lineageos.org/c/LineageOS/android_vendor_lineage/+/335207/ on or about 16th August specifically for Android 12.

The documented link Index of /pub/lineageos/full/sake/20220902 today contains vendor_boot.img dated 2022-09-02.

I have not dug any deeper but I believe this supports your assertion.

If this is correct, I think it should be reported. Report an issue. The link was probably valid when /e/ devs tested the device originally, but I believe the issue should be checked more deeply by experts.

1 Like

Hello @aibd

Thank you for looking into this. I’ll report the issue.
Should a solution be developed I’ll be happy to work my way back to /e/OS as it truly is a preferred OS over LineageOS for me.